How to more effectively get answers to your questions?

Introduction

This post will cover how to more effectively get answers to questions you have using Infragistics products. Note that if you have a license it is important for you to register your keys to ensure that you get the correct level of support when you post to our forums or submit support cases. If you need to register your key you can do so on this link.

For more details on how our support systems work, see this

When posting questions formatting the content properly will ensure efficiency.

Before You Ask

Before you ask your question, consider the possibility that your question has been asked before and an answer may already be posted. Searching for an existing answer may be quicker than posting a question and waiting for a reply:

1. Look for an answer by reviewing our product guidance materials on: http://www.infragistics.com/support/documentation.aspx#OnlineDocumentation .

2. Search using our get help page at : http://www.infragistics.com/support/get-help.aspx

3. If you do not find answers to your question on our website please post it to our community forums at : http://forums.infragistics.com/

4. If your questions are about related technologies to our product you may also consider searching the web.

When You Ask

First check out our latest Support Policy: http://www.infragistics.com/support/default.aspx#SupportPolicies

Note: Infragistics recommendation – for all existing customers there is no difference where they ask a question. In all cases they are going to receive a response in a timely manner and we recommend the forums, because:

· Our advanced support infrastructure which gathers and prioritizes all support requests depends on the user support level

· We have a large community (more than 500k active users) and skilled Developer Support Engineers

The title of your question

Selecting a good title for the question/thread will be the one of the main driving forces for the community to want to actually read and answer your forum post.

The question

Provide all the necessary information in your initial post.

If applicable include information from the following categories:

  • Describe the symptoms of your issue carefully and clearly.
  • Describe the environment in which it occurs (OS, browser, application, frameworks). Provide your Infragistics product version (e.g.: “Windows 7 Enterprise SP1 64bit”, “IE 8”, “Silverlight 4.0.60129.0”, “Infragistics Silverlight 10.3.20103.2117” and etc.).
  • Describe the research you have done.
  • When Exceptions occur, it’s often very helpful to post the Call Stack of the Exception
  • Describe the diagnostic steps you took to try and pin down the problem yourself before you asked the question
  • Describe the expected behavior.

Please don't let us assume, tell us right at the beginning.

Isolating an issue in a sample project

There are cases in which we simply cannot move forward without a project that would allow us to reproduce a specific issue locally in a controlled environment.

We usually ask for a sample project only after:

  • we have tried and couldn’t reproduce the reported issue by following your instructions
  • we have tried and couldn’t reproduce the reported issue by running the provided code snippet
  • we have tried and couldn’t reproduce the reported issue by intelligently predicting/guessing where the issue might be

You may follow the steps below to create isolated sample.

1. Clone the existing project – just to ensure that you will NOT lose any valuable data

2. Determine which controls, frameworks, data and code do not participate in the reproducing steps and are not needed to reproduce the issue. Often there are only 2-3 items which are directly involved in the reproducing steps, remove all other.

3. Move to separate simple project which reproduce the issue, by this way we will have really simple project using which we could easily reproduce and isolate the issue. Zip the project and attached it to your forum post/support ticket/email.

Screenshots

Sometimes it helps to send some screenshots or a movie that show the issue on your side. Here you can learn more how to create a screenshot at different OS:

http://en.kioskea.net/faq/141-print-screen-screen-capture-windows-mac-os-x-and-unix-linux

Follow-up

Follow up with a brief note on the solution. If one of the answers helped you, we would all like to know which one it was, and what you did to finally solve your problem. This is what an online community is all about - sharing information. Sharing information is not just by taking information from us, but also by sharing your success stories, and by helping others who might read your post in the future understand what the outcome of the thread was. Consider how you might be able to prevent others from having the same problem in the future.


Comments  (2 )

Prasad Menon
on Wed, Aug 29 2012 5:28 PM

I am trying to bind a toggle button to xam data grid (allowrecordfiltering), so that I can turn on the filter as and when required. I get the following error [System.Windows.Data Error: 2 : Cannot find governing FrameworkElement or FrameworkContentElement for target element. BindingExpression:Path=IsChecked; DataItem=null; target element is 'FieldSettings' (HashCode=53653601); target property is 'AllowRecordFiltering' (type 'Nullable`1')]. I have also provided the xaml here:

<Window x:Class="TestXamDataGridFilter.MainWindow"

       xmlns="schemas.microsoft.com/.../presentation"

       xmlns:x="schemas.microsoft.com/.../xaml"

       Title="MainWindow" Height="350" Width="525"

       xmlns:igDP="infragistics.com/DataPresenter">

   <Window.Resources>

       <BooleanToVisibilityConverter x:Key="BooleanToVisibilityConverter" />

   </Window.Resources>

   <StackPanel>

       <ToggleButton x:Name="toggle" Content="Toggle Search" />

       <igDP:XamDataGrid x:Name="grid1" BindToSampleData="True">

           <igDP:XamDataGrid.FieldSettings>

               <igDP:FieldSettings AllowRecordFiltering="{Binding IsChecked, ElementName=toggle, Converter={StaticResource BooleanToVisibilityConverter}}" />

           </igDP:XamDataGrid.FieldSettings>

       </igDP:XamDataGrid>

   </StackPanel>

</Window>

Any help would be much appreciated.

Thanks

Binaka Kumari
on Thu, Sep 13 2012 4:15 AM

Message: System.NullReferenceException: Object reference not set to an

instance of an object.

Source: Infragistics.WebUI.UltraWebNavigator.v5.3

URL: http://www.{Changed to protect the client}.com/Default.aspx

Stack Trace:    at

Infragistics.Shared.ClientMachine.UpdateEnvironmentInfo(Control c)

  at Infragistics.Shared.ClientMachine..ctor(Control c)

  at Infragistics.WebUI.UltraWebNavigator.UltraWebMenu.Render(HtmlTextWriter

output)

  at System.Web.UI.Control.RenderControl(HtmlTextWriter writer)

  at System.Web.UI.Control.RenderChildren(HtmlTextWriter writer)

  at System.Web.UI.Control.Render(HtmlTextWriter writer)

  at System.Web.UI.Control.RenderControl(HtmlTextWriter writer)

  at ASP.Default_aspx.__RenderfrmPage(HtmlTextWriter __output, Control

parameterContainer) in {Changed to protect the client}\Default.aspx:line 28

  at System.Web.UI.Control.RenderChildren(HtmlTextWriter writer)

  at System.Web.UI.HtmlControls.HtmlForm.RenderChildren(HtmlTextWriter writer)

  at System.Web.UI.HtmlControls.HtmlForm.Render(HtmlTextWriter output)

  at System.Web.UI.Control.RenderControl(HtmlTextWriter writer)

  at ASP.Default_aspx.__Render__control1(HtmlTextWriter __output, Control

parameterContainer) in {Changed to protect the client}\Default.aspx:line 21

  at System.Web.UI.Control.RenderChildren(HtmlTextWriter writer)

  at System.Web.UI.Control.Render(HtmlTextWriter writer)

  at WebApplication.PageBase.Render(HtmlTextWriter output)

  at System.Web.UI.Control.RenderControl(HtmlTextWriter writer)

  at System.Web.UI.Page.ProcessRequestMain()

Add a Comment

Please Login or Register to add a comment.