IE9 Support Plans for ASP.NET Controls

[Update 3/15/2011] - IE 9 shipped yesterday and Infragistics is going to continue testing with IE 9 RTM bits and will ship service release next month for 10.1, 10.2 & 10.3 as mentioned below. There is also a slight change in the 11.1 release date, and it is now due to release early May. 

 

Last week, IE 9 was shipped as a release candidate, which is expected to RTM at MIX this April. With the IE 9 release candidate, Infragistics started initial testing of the entire ASP.NET toolset against IE 9 and is projecting the 11.1 release time to be fully compatible with the latest IE 9 bits. The 11.1 release is expected to be ready by early April. Not only will the 11.1 release be fully compatible and supported against IE 9, but the support will be extended all the way back to the 10.1 volume release. It means that if you are using 10.1 or above, you can download the service release in April and be fully compatible with IE 9.  Also, the entire toolset will be tested and supported with IE 9 from 10.1 & up, including the classic ASP.NET controls. Please check out this blog post to learn more about the ASP.NET product changes that were announced last year.

If you would like to participate in testing, please report any issues you find to our support team, so that we can verify it fixed when we publish the service release. if you run into any issues with any of the controls or have any questions, feel free to send me an email at murtazaa@infragistics.com

 


Comments  (38 )

kuroczyd
on Thu, Mar 17 2011 8:23 AM

Hi Taz,

Thanks you for that very useful update. But it there any chance that your dev team could find some workaround for older versions for the specific problem of row selecting that is one of the biggest issues with IE9? As many users of your controls we are very good developers and we could adapt the workaround/fix for older versions. In my case, we have dozens of servers already in the field and it is easier to send to those customers a fix than a whole upgrade based on 11.1... Thanks for the answer. Daniel K.  

BCCORP
on Thu, Mar 17 2011 8:41 AM

With Internet Explorer 9 being officially released and the classic controls not being supported, this is definitely making it very difficult for our business to continue to use these controls.  We realize that IG has other controls available, but unfortunately our investment in the classic controls is quite heavy at this point.  Frankly, waiting until April is not an option for us.  We currently use version 10.3.  Is there any way to have a hotfix developed and released in a shorter timeframe so that at least the main classic controls (UltraWebGrid, etc) would work properly?  Most important for us is the "ClickCellButton" functionality.  This does not currently seem to work in IE9.

Any help, direction, or response is greatly appreciated.

Tim Friesen

BCCORP

[Infragistics] Murtaza Abdeali
on Thu, Mar 17 2011 9:46 AM

@Daniel - Shoot me an email, and I can see if we can provide you with just the changes (if they are only in javascript). But as you may already be aware, that will take you out of our support policies going forward. Best option would be to upgrade to a version 10.1 or above, and possibly consider moving to WebDataGrid or WebHierarchicalDataGrid for future development.

@Tim - Can you please report this to our support team. We have done a bunch of fixes and can send you a private build.

www.infragistics.com/.../submitrequest.aspx

Thanks,

Taz.

vwbank
on Tue, Mar 22 2011 2:11 PM

With Internet Explorer 9 being officially released we have the same problam as already posted by Tim. The classic controls are not supported. We currently use version 2007.1. and are not able to update to the newer versions. Is there any way to have a hotfix developed and released in a shorter timeframe so that at least UltraWebGrid and WebMenu controls would work properly? Most important for us is the "Select" functionality in the Grid. This does not currently work in IE9.

Any help, direction, or response is greatly appreciated.

Maciej Neumann

Volkswagen Bank

Germany

[Infragistics] Murtaza Abdeali
on Wed, Mar 23 2011 12:01 PM

Hello Maciej,

In the service release due around mid-April, 10.1 and above version of the ASP.NET will contain fixes for IE 9. We are supporting and prior version, so you will have to upgrade.

Sorry about any inconvenience. You can get a latest build, if you contact our developer support.

www.infragistics.com/.../submitrequest.aspx

-Taz.

alfmag
on Mon, Mar 28 2011 11:08 AM

I don't understand, we use version 9.2, if we upgrade 10.1, we have to swap the ultrawebgrid for the WebDataGrid?

[Infragistics] Murtaza Abdeali
on Mon, Mar 28 2011 1:24 PM

No, you don't have to swap the UltraWebGrid with the WebDataGrid if you upgrade to 10.1. If all you need is IE 9 supported bits for UltraWebGrid, then upgrading the application is all that you need. Longer term, you might want to consider replacing the UltraWebGrids with the WebDataGrids, as we will be retiring the UltraWebGrid soon.

-Taz

michaeldaseke
on Tue, Mar 29 2011 4:47 PM

From the little bit of debugging I have done today on the IE9 row select feature, I have identified the issue, but have been unable to fix it (without extensively modifying the javascript all the way up the inheritence chain).

This certainly SEEMS to be a javascript issue.  Is there any plans to release a javascript only patch to handle it?

I would really like to get past this issue to test any other potential issues in IE9.  We are planning an upgrade and our use of the grids is making it hard to test the rest of the application.

[Infragistics] Murtaza Abdeali
on Thu, Mar 31 2011 10:56 AM

@Michael - We are not planning on a JavaScript only patch. You could however download the service release when it comes out and try to replace the JavaScript file only to see if that fixes the issue. This is not something that we would recommend as a solution though, but it might get you going for now until you plan to do a full application upgrade.

-Taz.

rockcityghost
on Tue, Apr 12 2011 1:56 PM

"If all you need is IE 9 supported bits for UltraWebGrid, then upgrading the application is all that you need."

Can you please elaborate on this? What files can be taken from the 10.1 release to fix the ultrawebgrid?

sbeeler
on Tue, Apr 12 2011 3:52 PM

Tax,

This statement is alarming:  "Longer term, you might want to consider replacing the UltraWebGrids with the WebDataGrids, as we will be retiring the UltraWebGrid soon."

I have just spent the past couple of weeks unsuccesfully attempting to migrate an existing application from the UtraWebGrid to the WebDataGrid.  It has been an extremely unproductive, frustrating, unmitigated disaster.  The new controls are buggy (I have outstanding support requests...but no actual helpful support from Infragistics) and severly lacking in features when compared to the older asp.net controls.  I can appreciate that the new controls use a different framework and will require changes.  But removing functionality is simply not acceptable if you expect your customers to migrate to them.  How are we supposed to migrate to the new controls when they don't offer the same performance or capabilities of the old controls?

Given the delay in support for ie 9, and Microsoft's announcements of IE 10 today, why would those of us depending on the older more functional controls continue to use Infragistics products?  Should we interpret the statement that the Ultrawebgrid will soon be retired as an indication that it won't be updated to support the announced IE 10?

Given the lack of functionality and poor performance of the WebDataGrid vs the UltraWebGrid and the refusal by Infragistics to continue supporting the more functional older product, it sounds like our development team would unfortunately be better served moving to a competitors product rather than wasting any more time and effort with Infragistics.

estanito
on Wed, Apr 13 2011 8:50 AM

I agree with sbeeler, I couldn't say it better...

[Infragistics] Murtaza Abdeali
on Thu, Apr 14 2011 6:22 AM

@sbeeler, @estanito - Sorry to hear you are having trouble migrating the controls. We just shipped an IE 9 & FF 4 SR a couple of days ago and all the ASP.NET controls, including the classic controls were made fully compatible with these browser upgrades.

As for retiring these controls, it was not an easy decision for us. Due to the web trends changing since 2007, and emerging technologies coming out within the market place with standard upgrades, we had to build our ASP.NET stack from scratch to support the modern web that we all are experiencing today.

Can you please send me an email with your support cases, and I can further look into the matter for you. murtazaa@infragistics.com

-Taz.

nitinsraut
on Tue, Apr 19 2011 10:13 AM

With Internet Explorer 9 being officially released we have the same problam as already posted by Tim and Maciej. The classic controls are not supported. We currently use version 2007.1. and are not able to update to the newer versions.Today i downloaded the 10.3 version but still facing issue for ultrawebgrid to add new row. Is there any way to have a hotfix developed and released in a shorter timeframe so that at least UltraWebGrid and WebMenu controls would work properly? Most important for us is the "Select" functionality in the Grid. This does not currently work in IE9.

Any help, direction, or response is greatly appreciated.

Thanks

Nitin Raut

[Infragistics] Murtaza Abdeali
on Tue, Apr 19 2011 5:24 PM

Hi Nitin,

From the download's page of the ASP.NET product, get the latest service release and that should give you IE 9 compatible build.

www.infragistics.com/.../aspnet.aspx

-Taz

dsingal
on Tue, Apr 19 2011 6:49 PM

Hi Taz,

I just downloaded and installed the SR release and found that when the website runs as Browser Mode: Internet Explorer 9 and Document Mode: Quirks, I cannot click on the grid at all. It displays all the records fine but the click does not work. When I switch the Browser Mode to IE9 Compat View it works fine where the mouse and keyboard events work correctly as expected.

Not sure if this is a known problem. For our users we will have to ask them to click on the Compatibility View option of the browser for the controls to work correctly on IE9.

Thanks.

informed_direct
on Mon, Apr 25 2011 4:47 PM

*sigh* just upgraded to v10.3 SR2120 and for me too, the grid isn't responding to clicks and also the igcmbo:webcombo control doesn't work. The drop down box displays but when you select an item, it isn't selected - it stays showing the original setting. It's late and I haven't got the energy to start reducing my code down to examples that support can digest.

But if compatability mode works, then that will have to do until these bugs are fixed.

Rob.

ewolfman
on Tue, Apr 26 2011 11:59 AM

I installed v10.3 from scratch and modified the web.config to the new dlls, and still experience exactly the same issues as reported here (with or without Compatibility to IE8):

forums.infragistics.com/.../277631.aspx

During runtime I tested UltraWebGrid and saw that the type does originate from the new assemblies of v10.3. Here's the quickwatch output:

typeof(UltraWebGrid).Assembly {Infragistics4.WebUI.UltraWebGrid.v10.3, Version=10.3.20103.1013, Culture=neutral, PublicKeyToken=7dd5c3163f2cd0cb}.

Using a client debugger, the JavaScript which originates the problem looks exactly the same as in v9.2. I tried to force clean the cache but to no avail.

Finally, I created a tester to reproduce both issues (IE9 and IE8 compat mode) - will try to send to: murtazaa@infragistics.com

TargetIT
on Wed, Apr 27 2011 7:40 AM

Our problem is the grid displays the resultset but you cannot select a row on the grid, our site was working fine until IE9 came along.

The infragistics control set is used everywhere on our website and we have thousands of users, so far only 19 have gone over to IE9.

Has any one managed to get tthe Grid controls working fine in IE9. We are on version v5.3 and have downloaded the trial edition, but we require the service release which we cannot get access to because our agreement has expired.

I can't understand why this is not packaged with the trial edition?

We just want to trial this prove everything on UAT and then purchase if all is fine.

I have been told that we need to purchase v10.3 and then we can get the SR under the support agreement. However I don't want to get the company pay out the cash if this does not work.

Can someone from Infragistics email me the service release so we can try this.

Yours hopefully,

NJP

ewolfman
on Thu, Apr 28 2011 2:30 AM

Hi Taz,

Can you please provide an update on the status of things. I've sent you an email with a aspx files demonstrating the IE9 and IE8 compatibility issues with v10.3.

[Infragistics] Murtaza Abdeali
on Thu, Apr 28 2011 4:25 PM

@dsingal - Support has created a case# for you CAS-64451-2H31PHL. You can get in touch with them to get more details.

@informed_direct - Support has created a case# for you CAS-64453-NZST9K. You can get in touch with them to get more details.

@dartford - Send me an email and I will get you a private SR that you can apply to a 10.3 trial.

@ewolfman - Thanks for the sample. I have forwarded it to support and someone should be getting in touch with you soon.

-Taz.

garyrg9
on Tue, May 3 2011 2:43 PM

I agree 100% with sbeeler. We have tried working with the webdatagrid and could not get the JavaScript working to add rows. So it does not function for us. Yet you want us to give up the classic controls. Unfortunately we are now in a box. You are not going to support VS9.2 for IE9 and migrating to the "newer controls with less functionality" doesn't seem appealing and you are retiring the classic controls. So basically you have left us with our only option is a competitiors product.

Gary Goodwin(Long time user - now regretting it)

[Infragistics] Murtaza Abdeali
on Wed, May 4 2011 9:37 AM

Hi Gary,

Upgrading to newer controls is not necessary for IE 9 support. All the volume releases 10.1 and above are supported in IE 9 with their latest service release, including the classic controls. The newer controls are almost feature parity with the classic controls and with the release next month, we will be closing that gap further. Also, I would like to mention that the newer grid have some features and other browser support that the classic controls do not.

If you need help with the new controls like the webdatagrid, and are having trouble, I suggest you work with support.

www.infragistics.com/.../submitrequest.aspx

We will also be putting out some more guidance in the upcoming releases, so we hope that will help as well with upgrading applications.

Best,

Taz.

unitm
on Thu, May 5 2011 9:13 AM

Hi Taz,

we currently use 10.2 but don't have an active subscription anymore. Is there any chance that I can get a service release for ie9 for 10.2?

Regards

Stefan

jacksonkao
on Thu, May 5 2011 10:29 PM

Hi Taz,

We need to test 10.3 trial for IE9 Compatibility.

Please provide private SR for test.

my email is jacksonkao@msn.com

Thanks.

Rob Hudson
on Fri, May 6 2011 9:35 AM

Quick question...  The blog post mentions early April for release of 11.1.  Is it coming out soon?  Itching for the checkbox columns :)

[Infragistics] Murtaza Abdeali
on Fri, May 6 2011 1:12 PM

@Stefan - You can download the service release from your downloads page. www.infragistics.com/.../Default.aspx

@Jackson - Just sent you an email.

@Rob - Yes, the release got push to early June, so it is coming out soon. I can send the bits if you want, just shoot me an email. murtazaa@infragistics.com

trandus
on Tue, May 10 2011 8:54 AM

Hi Taz, we need to test 10.3 trial for IE9 Compatibility too, could you please provide us SR for test? Our app with IG9 does not work in IE9 and we cannot download your SR directly.

Thanks in advance

tomas.randus@data3s.com

habbasi
on Wed, May 11 2011 4:45 AM

@Murtaza - Assalam o Aluekum, I am using infragistic webgrid of Infragistics NetAdvantage 2006 Volume 2 CLR 1.0.

Having a same problem, In IE 9 the grid control does not accept any user interaction (cannot click on rows, multi-select or sort).

We don't want to upgrade our product to the latest Infragistics version as it won’t be as easy because there is so much customization code we have added on top of this old Infra version. Besides some users are also complaining on the forums that even after applying the patch on the latest version, the problem exists.

What are the possible solutions in my case? from where I can download latest javascript files for service release to fix this issue IE 9 Compatibility with NetAdvantage 2006?

habbasi
on Wed, May 11 2011 7:04 AM

Hi Taz,

We need to test 10.3 trial for IE9 Compatibility.

Please provide private SR for test.

my email is hassan_muet@hotmail.com

Thanks.

cloucas
on Wed, May 11 2011 11:07 PM

We have the same issue (when clicking a second cell on the UltraWebGrid 2010.3 we get the same exception).

We applied the service release proposed and still get the same error. Is there something additional that we need to do? Has anyone actually applied the patch and resolved the problem?  

Thanks

balu_b
on Wed, Jun 15 2011 5:31 AM

Hi,

I am facing the IE9 issue for Ultrawebgrid. as per available suggestions from the IG forums, i have applied Infra 10.3 version dll's in my application. but still i am facing the same issue. Please advice and provide me the feasible solution.

Thanks,

Balu.

balu_b
on Thu, Jun 16 2011 2:58 AM

Hi Everybody,

After using the Infragistics 2011.1 version, we are able to work on UltraWebGrid control in IE9 browsere.

Balu

mnr_foru
on Thu, Dec 1 2011 7:05 AM

Hi,

iam using asp.net 2.0 and netadvantages 2010.3, its shows some errors on ie9. netadvantages 2010.3 supports ie9 other wise

netadvantages 2011.1 supports asp.net 2.0

MNR

anuragsji
on Fri, Mar 16 2012 4:13 AM

We have an ASP.NET 4.0 web application which is being used Infragistics controls version 2006.1. We need the web application to run on IE9, for that we got to know from communications in Infragistics forums/ community that we need to use NetAdvantage for ASP.NET 2011 Vol. 2. We still want to use old controls like UltraWebGrid but NetAdvantage for ASP.NET 2011 Vol. 2 have new controls like WebDataGrid so we did not want to replace existing classic controls as that would be like entire application rewriting. Further we got the information from this blog post and other posts that NetAdvantage for ASP.NET 2011 Vol. 1 version has still old controls like UltraWebGrid and that version full support IE9.

We purchased a license for NetAdvantage for ASP.NET 2011 Vol. 2 and we also got license key for NetAdvantage for ASP.NET 2011 Vol. 1.

We downloaded the NetAdvantage for ASP.NET 2011 Vol. 1(NetAdvantage_ASPNET_20111_WithSamplesAndHelp) and also installed Patch (NetAdvantage_ASPNET_20111.2178_SR) and copied new Infragistics assemblies to my application and update references in web.config and on individual pages too. Also replaced both folders Images (C:\Program Files (x86)\Infragistics\NetAdvantage 2011.1\ASP.NET\Images) and Scripts (C:\Program Files (x86)\Infragistics\NetAdvantage 2011.1\ASP.NET\CLR4.0\Scripts) in web application.

Now application is using all controls of NetAdvantage for ASP.NET 2011 Vol. 1 version but I am continuously getting JavaScript error in ig_WebGrid_dom.js line 175 as:

filterPanel = this._filterPanels[this.ServerPassedFilters[itr]] = new igtbl_FilterDropDown(filteredColumn);

The error states as: Microsoft JScript runtime error: Unable to set value of the property 'parentNode': object is null or undefined.

This error is on IE9, the application is running OK on IE8 with these controls, few grid alignments and headertext font has changed but not this type of error.

Let us know If we are missing anything, all Infragistics DLLs have version as 11.1.20111.2178 for NetAdvantage for ASP.NET 2011 Vol. 1 after patch installed.

Please let me know how I can resolve the issue.

Best Regards

OMALBOSE
on Tue, Sep 18 2012 7:22 AM

Where can i find this release file?. Can anybody give the download link for the IE9 support release download link.

Thanks in advance

omal

chrisgou
on Tue, Aug 20 2013 9:17 PM

We have a  system use MS visual Studio 2005 and "NetAdvantage for .NET 2007 Vol. 3 CLR 2.0" , can you give us some advise how to upgrade NetAdvantage Controls, which version is the best we can support IE9.

  And we have 3 development environment options :

   1. MS visual Studio 2005 + NetAdvantage for .Net.

   2. MS visual Studio 2008 + NetAdvantage for .Net.

   3. MS visual Studio 2010 + NetAdvantage for .Net.

  Thanks.

chrisgou
on Tue, Aug 20 2013 9:20 PM

We have a  system use MS visual Studio 2005 and "NetAdvantage for .NET 2007 Vol. 3 CLR 2.0" , can you give us some advise how to upgrade NetAdvantage Controls, which version is the best we can support IE9.

  And we have 3 development environment options :

   1. MS visual Studio 2005 + NetAdvantage for .Net.

   2. MS visual Studio 2008 + NetAdvantage for .Net.

   3. MS visual Studio 2010 + NetAdvantage for .Net.

  Thanks.

  Email:gouxinya@gmail.com

Add a Comment

Please Login or Register to add a comment.