hide / disable tab panel in xamribbon

Answered (Not Verified) This post has 0 verified answers | 7 Replies | 4 Followers Thread's RSS feed.

ladia
Points 275
Replied On: Wed, Jul 8 2009 5:18 AM Reply

Hi

Is it possible to hide / disable the ribbon tab panel? I would just like to use the QAT and ApplicationMenu.

  • Post Points: 35

All Replies

Replied On: Wed, Jul 8 2009 4:50 PM Reply

You want to work with the IsMinimized property.  Setting it to true will hide the tab area.  The option to show it will still be in the context menus.  Do you want to not use it at all?

  • Post Points: 20
ladia
Points 275
Replied On: Thu, Jul 9 2009 2:40 AM Reply

Both variation (hide and not at all) would be good to know.

Setting IsMinimized to true worked but then i get a black "stripe" underneath:

How to solve this? Also how could i remove the option "Minimize The Ribbon" out of the customize QAT menu?

 

  • Post Points: 35
Answered (Not Verified) Replied On: Fri, Jul 10 2009 9:44 AM Reply

The control is designed to mimic the Office UI Ribbon and to meet the requirements set forth in the Microsoft Office UI Guidelines - the guidelines to which you must adhere to be licensed by Microsoft to be able to use any ribbon ui within your application. Those guidelines require the use of tabs and as such the xamRibbon's template is set up to expect one or more tab items. If this were allowed by the ui guidelines, you would have to retemplate the xamRibbon and determine how you want to layout the elements.

With regards to the Minimize the Ribbon option, you would have to set the AllowMinimize to false.

  • Post Points: 20
ladia
Points 275
Replied On: Fri, Jul 10 2009 10:32 AM Reply

Ok, i'm now using TabItem. Is it possible to change the RibbonGroup border (e.g. thicker, none etc) without templating it?

  • Post Points: 20
Replied On: Fri, Jul 10 2009 11:28 AM Reply

The ribbon group's border is more elaborate than a simple border so that look and feel could not be accomplished with a single border. To change the border thickness/visibility you would need to retemplate it. The default xaml is included in the DefaultStyles directory and you can use this as the basis for your custom template.

  • Post Points: 5
smiket
Points 30
Replied On: Sun, Oct 18 2009 9:09 PM Reply

This worked for me:

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

<igRibbon:RibbonWindowContentHost

>

 

 

 

<igRibbon:RibbonWindowContentHost.Ribbon

>

 

 

 

<igRibbon:XamRibbon Name="xamRibbon1" VerticalAlignment="Top" IsMinimized="True" Height

="31">

 

 

 

<igRibbon:XamRibbon.ApplicationMenu

>

 

 

 

<igRibbon:ApplicationMenu Visibility

="Collapsed" />

 

 

 

</igRibbon:XamRibbon.ApplicationMenu

>

 

 

 

<igRibbon:XamRibbon.QuickAccessToolbar

>

 

 

 

<igRibbon:QuickAccessToolbar Visibility

="Collapsed" />

 

 

 

</igRibbon:XamRibbon.QuickAccessToolbar

>

 

 

 

</igRibbon:XamRibbon

>

 

 

 

</igRibbon:RibbonWindowContentHost.Ribbon

>

 

 

 

<DockPanel Background

="AliceBlue">

 

 

 

<Grid Name

="grid1">

 

 

 

<TextBlock>Content...</TextBlock

>

 

 

 

</Grid

>

 

 

 

</DockPanel

>

 

 

 

</igRibbon:RibbonWindowContentHost

>

  • Post Points: 5
Mauricio Feijo
Points 80
Replied On: Thu, Jun 2 2011 1:10 PM Reply

If you can live with the hacking feeling of it, you can set the top margin of your content to -20 and the black stripe will go away. Note that the button on the left will be positioned over your content, which may be a desired behavior, or not.

 

    <igRibbon:RibbonWindowContentHost>
        <igRibbon:RibbonWindowContentHost.Ribbon>

...

        </igRibbon:RibbonWindowContentHost.Ribbon>
        <DockPanel LastChildFill="True" Margin=0,-20,0,0>

  • Post Points: 5
Page 1 of 1 (8 items) | RSS