Infragistics WinfowForms trail period has expired

Answered (Not Verified) This post has 0 verified answers | 4 Replies | 2 Followers Thread's RSS feed.

Alvin Cates
Points 135
Replied On: Thu, Jul 16 2015 9:47 AM Reply

Ok folks we have purchased our license. the warning when our application is run is gone, but when we try to edit any of the screen in Visual studio we get this message:

Infragistics WinfowForms trail period has expired

I have done to following steps to no avail.

1. Select all Infragistic`s assemblies from Reference folder and set property “Specific version = False”
2. Open the licenses.licx and delete the content. Save changes.
3. Clean your solution
4. Rebuild your solution.

I will point out that my  licenses.licx  file was already empty. This is because I had the same issues when 1 got an extension to our initial trial period and you help desk guy had me clear it which worked but now the issues has returned.

  • Post Points: 20

All Replies

Michael DiFilippo
Points 22,005
Infragistics Employee
Answered (Not Verified) Replied On: Thu, Jul 16 2015 3:33 PM Reply
Suggested by Michael DiFilippo

Hello Alvin,

Thank you for contacting Infragistics. May I ask which version of Infragistics, platform your using, and version of Visual Studio/DotNet framework the application is built with?

A few mentions to try:

1. Uninstall/Reinstall the version of Infragistics completely as administrator via the Platform installer (do not use any MSI files).
 a. Retype your new licence key
2. Make sure the license assembly is located in the GAC (see regedit path below)
3. Check SerialNumber for your key entered after installing:

HKEY_CLASSES_ROOT\Infragistics\NetAdvantage\NET\Full\WinForms\

Let me know if you have any questions regarding this matter.

Sincerely,

Michael Di Filippo
Associate Software Developer

  • Post Points: 20
Alvin Cates
Points 135
Replied On: Wed, Jul 22 2015 3:01 PM Reply

Michael,

We are using version 2015 with VS 2013.

I have followed the  steps you have listed and the package installed correctly. and the serial number in the registry matches  which was located  at HKEY_CLASSES_ROOT\Infragistics\NetAdvantage\NET\CLR2x\Version15.1\SerialNumber not the path you listed . I can create a new windows project and add controls with no issues, however when I go to our existing  windows project( which was upgraded from 9.1 to 2015) and open a form in design mode I get the following error:

Could not load file or assembly 'Infragistics4.Win.UltraWinToolbars.v15.1, Version=15.1.20151.2013, Culture=neutral, PublicKeyToken=7dd5c3163f2cd0cb' or one of its dependencies. The system cannot find the file specified. 

If I look at the properties of the installed DLL I see this version number

15.1.20151.2132

Let me mention that the the application builds and runs just fine. The only issue is trying to open a form in design mode

  • Post Points: 20
Michael DiFilippo
Points 22,005
Infragistics Employee
Answered (Not Verified) Replied On: Wed, Jul 22 2015 3:18 PM Reply
Suggested by Michael DiFilippo

Hello Alvin,

Thank you for following up. The project(s) might still be holding onto the old version (2013) build which is stamped in the License.licx file. You can find this file in the properties window in Solution Explorer. Please clear any entries in that file and do a clean and rebuild. This should force the app to compile with the latest assemblies.

Let me know if you have any questions regarding this matter.

Sincerely,

Michael Di Filippo
Associate Software Developer

  • Post Points: 20
Alvin Cates
Points 135
Replied On: Fri, Jul 24 2015 8:22 AM Reply

My licenses.licx was already empty, but removing  and adding the reference to the DLL in the project a couple of times and saving after each change cleared up the issue. Go figure :)

 

  • Post Points: 5
Page 1 of 1 (5 items) | RSS