Failed To Create Component UltraGrid

Answered (Not Verified) This post has 0 verified answers | 8 Replies | 7 Followers Thread's RSS feed.

exuviae
Points 360
Replied On: Thu, Nov 12 2009 8:26 AM Reply

We have licenses for 2009.2 with service release 1.  However i can no longer use the product after installing it.  If i try to work with a project that already contains a grid, visual studio crashes and has to restart.  If i create a new project and drop a grid on the form, i get this:

"Failed to Create Component UltraGrid :  The error messages is as follows "Failed to compare two elements in the array".

Basically I am unable to work on any project that contains the infragistics components.  I am on an extrememely tight deadline and have worked 3 weeks straight.  Can anyone help me get this resolved?  I sure would hate to work yet another weekend.

  • Post Points: 20

All Replies

Mike Saltzman
Points 439,405
Infragistics Employee
Answered (Not Verified) Replied On: Thu, Nov 12 2009 10:03 AM Reply
Suggested by Mike Saltzman

Get the latest service release. I believe this issue was already fixed.

How to get the latest service release - Infragistics Community

Mike Saltzman

Manager - Windows Forms Development

Infragistics, Inc.

  • Post Points: 20
exuviae
Points 360
Replied On: Thu, Nov 12 2009 10:10 AM Reply

I am using the latest service release for win forms  2009.2 SR1 which is 9.2.20092.2017 right??  Is there a service release beyond that one?

 

  • Post Points: 35
Replied On: Fri, Oct 22 2010 8:05 AM Reply

I believe the infragistic's installation(.dll' s  of the infragistic components

in the choose tollbox items list) is not being picked by the visual studio frame work (4.0) and

it is being picked by visual studio frame work (2.0)

  • Post Points: 5
Mike Saltzman
Points 439,405
Infragistics Employee
Replied On: Fri, Oct 22 2010 10:41 AM Reply

The latest service release for NetAdvantage 2009 Vol 2 is build 2106. 2017 is much older.

Mike Saltzman

Manager - Windows Forms Development

Infragistics, Inc.

  • Post Points: 20
Oliver
Points 295
Replied On: Wed, May 29 2013 3:06 AM Reply

Hi Infragistics Team,

unfortunately I have this issue with Version 12.1

I've installed last service release but still happens.

Any idea what I can do?

 

Thanks & Regards,

Oliver

 

  • Post Points: 20
Replied On: Tue, Jun 11 2013 7:33 AM Reply

Hello Oliver,

Could you please let me know of the steps to reproduce this issue and if possible to attach a small sample project?


Best regards,

Boris

Developer Support Supervisor, MCPD
Infragistics, Inc.

How to get answers =>

  • Post Points: 20
kosiol
Points 40
Replied On: Thu, Oct 17 2013 4:27 AM Reply

Hi Infragistics Team,

I have the same problem like Oliver. I installed the new version of infragistics 12.1 on my new pc. Now i can't use the designer in our projects with an older version of 12.1. I added a sample project. In this project i try to add a new UltraButton and get an error message.

Regards

Bastian

  • Post Points: 20
[Infragistics]Hristo
Points 39,486
Infragistics Employee
Replied On: Thu, Oct 17 2013 7:48 AM Reply

Hello,

Please close all designers of Visual Studio in your solution, select all Infragistics references from the “Solution Explorer ” for all projects of your solution and go to “Properties Explorer” in order to set “Specific Version” of all Infragistics references of your solution to false. Then for each of your projects in your solution find licenses.licx file and clean  its content from all Infragistics entries and save the file. Clean and rebuild your solution, now you should be able to use designer.

Please let me know if you have any further questions.

Sincerely,
Hristo
Developer Support Engineer
Infragistics, Inc.

  • Post Points: 5
Page 1 of 1 (9 items) | RSS