WHGD wont expand on auto load on demand

Not Answered This post has 0 verified answers | 2 Replies | 1 Follower Thread's RSS feed.

frengineer
Points 35
Replied On: Tue, Oct 25 2011 5:33 PM Reply

Hi, I am using WHGD version 11.1.20111.2064, I'm usinng VS2008 SP1 and .Net3.5 on IE9. I followed the exact sample on this link:

http://samples.infragistics.com/aspnet/Samples/WebHierarchicalDataGrid/Performance/LoadOnDemand/Default.aspx?cn=hierarchical-data-grid&sid=b97e3a58-a6c2-4327-b289-de68335559f4

It will load the parent root on first load, but when I click on expand button, it will show the ajax loader but wont expand the child rows. Please help. Here's my code:

<%@ Page Language="C#" AutoEventWireup="true" CodeBehind="Default.aspx.cs" Inherits="SRSNewItems._Default" %>

<%@ Register Assembly="Infragistics35.Web.v11.1, Version=11.1.20111.2064, Culture=neutral, PublicKeyToken=7dd5c3163f2cd0cb" Namespace="Infragistics.Web.UI" TagPrefix="ig" %>

<%@ Register Assembly="Infragistics35.Web.v11.1, Version=11.1.20111.2064, Culture=neutral, PublicKeyToken=7dd5c3163f2cd0cb" namespace="Infragistics.Web.UI.GridControls" tagprefix="ig" %>

<%@ Register Assembly="Infragistics35.Web.v11.1, Version=11.1.20111.2064, Culture=neutral, PublicKeyToken=7dd5c3163f2cd0cb" namespace="Infragistics.Web.UI.DataSourceControls" tagprefix="ig" %>

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

<!

 

DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"

>

<

 

html xmlns="http://www.w3.org/1999/xhtml"

>

<

 

head runat="server"

>

 

 

<title></title

>

</

 

head

>

<

 

body

>

 

 

<form id="form1" runat="server"

>

 

 

<div

>

 

 

<ig:WebScriptManager ID="WebScriptManager1" runat="server"

>

 

 

</ig:WebScriptManager>

 

 

<ig:WebHierarchicalDataGrid

 

 

ID="WebHierarchicalDataGrid1"

 

 

runat="server"

 

 

Height="700px"

 

 

Width="700px"

 

 

DataSourceID="WebHierarchicalDataSource1"

 

 

DataKeyFields="First_Move_Date"

 

 

DataMember="SqlDataSourceSummary_DefaultView"

 

 

AutoGenerateBands="False"

 

 

AutoGenerateColumns=

"False"

 

 

Key="SqlDataSourceSummary_DefaultView" >

 

 

<ExpandCollapseAnimation SlideCloseDuration="300" SlideOpenDuration="300" />

 

 

<Bands

>

 

 

<ig:Band AutoGenerateColumns="False" DataMember="SqlDataSourceDept_DefaultView" Key="SqlDataSourceDept_DefaultView"

>

 

 

<Columns

>

 

 

<ig:BoundDataField DataFieldName="Dept_Name" Key="Dept_Name"

>

 

 

<Header Text="Dept Name"

/>

 

 

</ig:BoundDataField

>

 

 

</Columns

>

 

 

</ig:Band

>

 

 

</Bands

>

 

 

<Columns

>

 

 

<ig:BoundDataField DataFieldName="First_Move_Date" Key="First_Move_Date"

>

 

 

<Header Text="Move Date"

/>

 

 

</ig:BoundDataField

>

 

 

</Columns

>

 

 

</ig:WebHierarchicalDataGrid

>

 

 

 

<ig:WebHierarchicalDataSource ID="WebHierarchicalDataSource1" runat="server"

>

 

 

<DataRelations

>

 

 

<ig:DataRelation ChildColumns="First_Move_Date"

 

 

ChildDataViewID="SqlDataSourceDept_DefaultView" ParentColumns="First_Move_Date"

 

 

ParentDataViewID="SqlDataSourceSummary_DefaultView"

/>

 

 

</DataRelations

>

 

 

<DataViews

>

 

 

<ig:DataView ID="SqlDataSourceSummary_DefaultView" DataMember=

"DefaultView"

 

 

DataSourceID="SqlDataSourceSummary"

/>

 

 

<ig:DataView ID="SqlDataSourceDept_DefaultView" DataMember=

"DefaultView"

 

 

DataSourceID="SqlDataSourceDept"

/>

 

 

</DataViews

>

 

 

</ig:WebHierarchicalDataSource

>

 

 

 

<asp:SqlDataSource ID="SqlDataSourceDept" runat="server"

 

 

ConnectionString="<%$ ConnectionStrings:CnnStr %>"

 

 

SelectCommand="usp_Get_New_Items_Loss_Proj_Dept"

 

 

SelectCommandType="StoredProcedure"></asp:SqlDataSource

>

 

 

<asp:SqlDataSource ID="SqlDataSourceSummary" runat="server"

 

 

ConnectionString="<%$ ConnectionStrings:CnnStr %>"

 

 

SelectCommand="usp_Get_New_Items_Loss_Proj_Summary"

 

 

SelectCommandType="StoredProcedure"></asp:SqlDataSource

>

 

 

 

<ig:WebExcelExporter ID="WebExcelExporter1" runat="server"

 

 

DataExportMode="AllDataInDataSource" DownloadName="test"

>

 

 

</ig:WebExcelExporter

>

 

 

<asp:Button ID="Button1" runat="server" onclick="Button1_Click" Text="Export"

 

 

Width="71px"

/>

 

 

</div

>

 

 

</form

>

</

 

body

>

</

 

html

>

  • Post Points: 35

All Replies

Replied On: Fri, Mar 2 2012 7:32 AM Reply

Hi frengineer,

It has been some time since your post, however in case you still need assistance I would be glad to help.

After investigating the code you have provided I can spot no issues with the way load on demand is setup for your grid. I can suggest that you ensure that the relation defined in your datasource is operating as expected. If the issue persists I would need a small sample illustrating the matter in order to investigate this further.

Please feel free to contact me if you have any questions.

Best Regards,

Petar Ivanov
Developer Support Engineer
Infragistics, Inc.


  • Post Points: 5
dev_here
Points 1,965
Replied On: Thu, Jul 5 2012 6:16 PM Reply

Were you able to get this to work?

  • Post Points: 5
Page 1 of 1 (3 items) | RSS