Your Privacy Matters: We use our own and third-party cookies to improve your experience on our website. By continuing to use the website we understand that you accept their use. Cookie Policy
3760
igniteUI MVC igGrid not loading if Hiding column
posted

I have a simple Razor grid which works fine if in Hiding the Hidden is false.

@(Html.Infragistics().Grid(Model)
.ID("recordreviewlistgrid")
.Width("100%")
.Height("100%")
.PrimaryKey("Reference")
.Columns(column =>
{
column.For(m => m.Reference).HeaderText("Ref").Width("10%");
column.For(m => m.Details).HeaderText("Details1").DataType("String").Width("30%");
})
.Features(feature =>
{
feature.Hiding()
.ColumnSettings(cs =>
{
cs.ColumnSetting().ColumnKey("Reference").AllowHiding(false).Hidden(false);
cs.ColumnSetting().ColumnKey("Details").AllowHiding(false).Hidden(false);
});
})
.DataBind()
.Render()
)

If I change the Hidden property to true the column header is shown as hidden but no data rows are displayed: 

cs.ColumnSetting().ColumnKey("Details").AllowHiding(true).Hidden(true);

Can you see any reason why this should behave in this way. 

Thanks

Andy

  • 1080
    Offline posted

    Hello Andy,

    Thank you for posting in our community.

    I have created and attached a sample trying to reproduce the issue. On my side, everything is working as expected. The data rows are displayed correctly when the Hidden property is changed to true.

    Please test it on your side and let me know how it behaves. If this is not an accurate demonstration of what you are trying to achieve please feel free to modify it and send it back to me. Alternatively, if the behavior cannot be replicated please feel free to provide your own sample. Remove any external dependencies and code that is not directly related to the issue, zip your application and attach in in this case.

    Having a working sample on my side, which I can debug, is going to be very helpful in finding the root cause of this behavior.

    Thank you for your cooperation. 

    Sample.zip