Your Privacy Matters: We use our own and third-party cookies to improve your experience on our website. By continuing to use the website we understand that you accept their use. Cookie Policy
Enabling Multiselect on a grid model

Hi there,

I am working on an application where multiselect is a must. Conveniently, the selection behavior can be found on the igniteUI page here: in the second example (multiple row selection). Unfrotunately, when I attempt to set up my application to have multiple row selection my application does everything but select what I need it to.

When I left click, if there isn't anything else selected, it will select that first item, after that though, it won't change the selection in anyway unless I hold control or shift while trying to select. While holding control I have to double click to get the selection to change, admittedly the ctrl + double click has the expected behavior a ctrl+single click would have but that isn't the behavior that I need. For the shift click instead of selecting all of the rows between the last row and the newly clicked row the application simply selects the first row...

I've attached my code, a controller, a view, and a static class that I am using to do most of gridModel instantiation (I had this issue before I moved the code there it used to be in my controller, then in my view and then I decided I didn't like either of those so I moved it to this static class), but I don't think anything but lines 27-34 in CustomGridModel is effecting it. I do have other features that I am adding to the gridModel as you can see but I tried disabling all of them and got the same result.

Any ideas? Or do you need any more information?

Thanks in advance!