840
no intellisense
posted

Ive just started trying out infragistics and am following the Grid -> basic editing sample.  For no reason I can see, intellisense has just randomly stopped working.  It was working ok to start with, then stopped.  Can anyone tell me why this could happen ?  This is my view code

@using Infragistics.Web.Mvc
@using ViewModels.Contracts
@model IQueryable<ViewModels.Contracts.ContractViewModel>

@{
Layout = null;
}

<!DOCTYPE html>

<html>
<head>
<title></title>

<style type="text/css">
input.button-style {
margin-top: 10px;
}
</style>
</head>
<body>

@(Html.Infragistics()
.Grid(Model)
.ID("Grid")
.Height("500px")
.Width("100%")
.AutoGenerateColumns(false)
.AutoGenerateLayouts(false)
.RenderCheckboxes(true)
.PrimaryKey("ContractId")
.Columns(column =>
{
//column.For(x => x.ContractId).HeaderText("Contract ID").Width("10%");
column.For(x => x.ContractDate).HeaderText("Contract Date").Width("15%");
column.For(x => x.ContractEndUserOrg).HeaderText("Org Id").Width("20%");
column.For(x => x.ContractOrgName).HeaderText("Org Name").Width("25%");
column.For(x => x.ContractCurrency).HeaderText("Currency").Width("10%");
column.For(x => x.ContractStartDate).HeaderText("Start Date").Width("15%");

})
.Features(feature =>
{
feature.Updating().ColumnSettings(cs =>
{
//cs.ColumnSetting().ColumnKey("ContractId").ReadOnly(true);
cs.ColumnSetting().ColumnKey("ContractDate").EditorType(ColumnEditorType.DatePicker).Required(true);
cs.ColumnSetting().ColumnKey("ContractEndUserOrg").Required(true);
cs.ColumnSetting().ColumnKey("ContractOrgName").Required(true);
cs.ColumnSetting().ColumnKey("ContractCurrency").Required(true);
cs.ColumnSetting().ColumnKey("ContractStartDate)").Required(true).EditorType(ColumnEditorType.Date);
});
feature.Sorting();
})
.DataSourceUrl(Url.Action("GetContracts"))
.UpdateUrl(Url.Action("ContractsSaveData"))
.DataBind()
.Render()
)

there is no longer any intellisense so i cant select things like object properties, so if I type

column. ----- nothing !, no suggestions

anyone help ?