Your Privacy Matters: We use our own and third-party cookies to improve your experience on our website. By continuing to use the website we understand that you accept their use. Cookie Policy
15
IgGrid Dialog input problem
posted
Hi everybody,

I have an iggrid with edit mode set to dialog.
When I open the dialog to modify a row, the numeric fields have a comma, but I want them to be integers.
If I select the textbox the comma
disappears.

Thanks a lot
Stefano
  • 16950
    Offline posted

    Hello Stefano,

    Thank you for posting in our community.

    How numbers are displayed in your editing dialog`s inputs depends on the underlying data source in combination with the regional settings that you have applied.

    Having this in mind, please take a look at the attached sample where Unit Price column is of a type numeric. I have explicitly set the numericDecimalSeparator to ",". 

    For example:

    $.ig.regional.defaults.numericDecimalSeparator = ","

    If this sample is not an accurate demonstration of what you are tying  to achieve please feel free to modify it (the grid configuration as well as the values in the data source) and send it back to me with more information and steps to reproduce.

    Some additional information regarding formatting the display values of numbers can be found here.

    Looking forward to hearing from you.

    8055.igGridUpdatingDialogNumericEditor.zip