Your Privacy Matters: We use our own and third-party cookies to improve your experience on our website. By continuing to use the website we understand that you accept their use. Cookie Policy
15
Ignite UI: ASP.NET MVC: $(...).igGrid is not a function TypeError
posted

Hi

I am new at Infragistics and I get some error messages that I could not solve. I'm using ASP.NET MVC (.NET framework 4.6.1) with JQuery 3.0.0. I followed the getting started guide (https://www.igniteui.com/help/iggrid-developing-asp-net-mvc-applications-with-iggrid#getting-started) and I get this errors:

I am new to Infragistics and I get a number of error messages that I cannot resolve. I use ASP.NET MVC (.NET framework 4.6.1) with JQuery 3.0.0. I have followed the getting started guide (www.igniteui.com/.../iggrid-developing-asp-net-mvc-applications-with-iggrid and get the following error messages:

The grid is not showing because of this.

I started with JQuery version 3.3.1, but I found a message about how there are problems with this version. That is why I am now using version 3.0.0.

In the BundleConfig file I have created these bundles:

Which I use in my view as @Scripts.Render("~/bundles/IgniteUI") and @Scripts.Render("~/bundles/IgniteUI/css").

I also added the proper usings to my view:
        @using FremachWebApps.Areas.Diepenbeek.Models
        @using Infragistics.Web.Mvc

Then I wanted to add the grid to my view as followed: @(Html.Infragistics().Grid(Model.labotTimeGridModel)).
My model is a viewmodel with a GridModel and some other Lists.

According to the getting started guide, this would be enough, but I still get these errors. In the devtools I can see that my datasource is found and the records are included.

Is there something else I should do to fix this JQuery issue? Also why am I getting an unexpected token error on the css files of Infragistics?

Thanks you.