Your Privacy Matters: We use our own and third-party cookies to improve your experience on our website. By continuing to use the website we understand that you accept their use. Cookie Policy
30
Grid is not displayed after upgrading ingine ui to 2019.1
posted

I have downloaded and installed the infrgistics v 2019.1 and replace some dll. But now ingnite UI grid as not displaying. I have replaced below dll. Could you please help me to resolve this issue?

 

File Name/Folder Name

Old Version

New Version

Infragistics.Web.Mvc

5.16.1.1009

5.19.1.12

Infragistics45.WebUI.Documents.Core.v13.2

13.2.20132.1003

19.1.20191.115

Infragistics45.WebUI.Documents.Excel.v13.2

13.2.20132.1003

19.1.20191.115

IgniteUI/CSS

2018.1

2019.1

IgniteUI/js

2018.1

2019.1

IgniteUI/MVC5

2018.1

2019.1

 

Below is code snippet for reference

 

<link href="~/IgniteUI/css/themes/infragistics/infragistics.theme.css" rel="stylesheet" />

<link href="~/IgniteUI/css/structure/infragistics.css" rel="stylesheet" />

<script src="~/Scripts/modernizr-2.8.3.js"></script>

<script src="~/Scripts/jquery-1.11.3.min.js"></script>

<script src="~/Scripts/jquery-ui.min.js"></script>

 

<!-- Ignite UI Required Combined JavaScript Files -->

<script src="~/IgniteUI/js/infragistics.core.js"></script>

<script src="~/IgniteUI/js/infragistics.lob.js"></script>

<script src="~/IgniteUI/js/infragistics.loader.js"></script>

<script src="~/IgniteUI/js/modules/infragistics.util.js"></script>

<script src="~/IgniteUI/js/modules/infragistics.util.jquery.js"></script>

<script src="~/IgniteUI/js/modules/infragistics.datasource.js"></script>

<script src="~/IgniteUI/js/modules/infragistics.ui.shared.js"></script>

<script src="~/IgniteUI/js/modules/infragistics.ui.editors.js"></script>

<script src="~/IgniteUI/js/modules/infragistics.ui.grid.framework.js"></script>

<script src="~/IgniteUI/js/modules/infragistics.ui.grid.filtering.js"></script>

<!-- Used to add modal loading indicator for igGrid -->

 

<script src="~/IgniteUI/grid-modal-loading-inicator.js"></script>

<style type="text/css">

    input.button-style {

        margin-top: 10px;

    }

</style>

 

@if ((bool)@ViewData["ReadOnly"] == false)

{

    @(Html.Infragistics()

        .Grid(Model)

        .ID("Grid")

        .Height("600px")

        .Width("1200px")

        .AutoGenerateColumns(false)

        .AutoGenerateLayouts(false)

        .RenderCheckboxes(true)

        .PrimaryKey("BreakID")

        .FixedHeaders(false)

        .Columns(column =>

        {

})

 

Please let me know what is missing. Let me know if you need more information from my side.

  • 17270
    Offline posted

    Hello,

    Thank you for posting in our community.

    Here you will fins a working sample illustrating your scenario.

    Please test it on your side and let me know how it behaves.