Your Privacy Matters: We use our own and third-party cookies to improve your experience on our website. By continuing to use the website we understand that you accept their use. Cookie Policy
635
progress indicator in ultrawebtree
posted

Hi, I am using ultrawebtree control in my page of infragistics version 8.2.I am loading nodes from database on page load. On treenode expand i am again populating child treenodes from database.I want to show loading image icon on following cases 1) node expand 2) When first time tree is loading. I have tried it using updateprogress but its not showing waiting icon or text .How to achieve it. my aspx page contains following code.

                    <div id="MyTreeDiv" style="position: absolute; left: 0px; right: 0px; top: 50px;
                        overflow: auto; bottom: 40px; width: 100%">
                        <asp:UpdatePanel ID="UpdatePanel1" runat="server" UpdateMode="Conditional" RenderMode="Inline">
                            <ContentTemplate>
                                <script type="text/javascript">
                                    Sys.Application.add_load(placeUP);
                                </script>
                                <asp:Panel ID="pnl" runat="server" Visible="true" Width="100%">
                                    <ignav:UltraWebTree ID="TreeView1" runat="server" EnableAppStyling="False" EnableViewState="true" LoadOnDemand="Manual"
                                        Selectable="true" CssClass="featureTree" Style="cursor: pointer;
                                        overflow: visible; display: block; position: absolute; height: 100%; top: 0px;
                                        width: auto; bottom: 5px;" EnableTheming="false" Visible="true" AutoPostBack="false"
                                        ClientIDMode="Static" WebTreeTarget="ClassicTree" OnNodeClicked="TreeView1_NodeClicked"
                                        OnNodeExpanded="TreeView1_NodeExpanded">
                                        <%--<ClientSideEvents NodeExpand="OnExpandClick(event);" />--%>
                                        <%--<ClientSideEvents InitializeTree="func_initializeTree" DemandLoad="func_demandLoad" />--%>
                                    </ignav:UltraWebTree>
                                </asp:Panel>
                            </ContentTemplate>
                            <Triggers>
                                <asp:AsyncPostBackTrigger ControlID="TreeView1" EventName="NodeExpanded" />
                                <%--<asp:PostBackTrigger ControlID="TreeView1" />--%>
                                <asp:AsyncPostBackTrigger ControlID="rpsearch" EventName="ItemCommand" />
                            </Triggers>
                        </asp:UpdatePanel>
                        <asp:UpdateProgress  AssociatedUpdatePanelID="UpdatePanel1"  runat="server" DisplayAfter="0" DynamicLayout="true">
                        <ProgressTemplate>
                            <div style="position: relative; top: 30%; text-align: center;">
                                <img src="../icons/Loader.gif" style="vertical-align: middle" alt="Processing" height="50px" />
                            </div>
                            
                        </ProgressTemplate>
                    </asp:UpdateProgress>
                    </div>

Parents
No Data
Reply Children
No Data