Your Privacy Matters: We use our own and third-party cookies to improve your experience on our website. By continuing to use the website we understand that you accept their use. Cookie Policy
Unable to get Header values of UltraGridTestObject Table

I am trying to get the headers of the table (In the picture Highlighted with red colour) using following ways. But here the number of rows are coming as "zero". Every time I am getting error as "IndexArrayOutofBoundException" because of the Rows is "zero".

Below "grdRebalanceSetuptable" is the Table name of the object.


I tried another way:


But it is not giving the correct Header names. It is giving some other values.

Another way:

I tried by getting the childrens of the table. Also tried by getting all the propeties of the table. But I am unable to get the Header values of the table.


From the propeties I checked one by one as below to get the header values.

grdRebalanceSetuptable().getProperty("current row"));

Please give me your suggestions to get the Headers of the attached image table. The attached image window is a popup window which is coming after clicking an icon in the application.