Your Privacy Matters: We use our own and third-party cookies to improve your experience on our website. By continuing to use the website we understand that you accept their use. Cookie Policy
15
AutoSelectOnMatch="false" is not working
posted

<asp:GridView ID="GV1" runat="server" ShowFooter="True" style=" z-index:1;" AutoGenerateColumns="False" Width="100%" Height="100%" HeaderStyle-CssClass="headers" CssClass="mygrdContent" BorderWidth="3px" OnRowDataBound="GV1_RowDataBound">
<Columns>
<asp:TemplateField HeaderText="Product" HeaderStyle-Width="300px">
<ItemTemplate>
<asp:UpdatePanel ID="UpdatePanel1" runat="server">
<ContentTemplate>


<ig:WebDropDown ID="DD_PRODUCT" OnSelectionChanged="DD_PRODUCT_SelectionChanged" runat="server" Width="300px" Height="30px" onkeydown="return (event.keyCode!=13)" KeepFocusOnSelection="true" NullText="Select" AutoPostBack="true" AutoSelectOnMatch="false" EnableAutoCompleteFirstMatch="true" >
<AutoPostBackFlags SelectionChanged="On" ValueChanged="Off" />
</ig:WebDropDown>
</ItemTemplate>
</asp:TemplateField>

</Columns>
</asp:GridView>

  • 1660
    Offline posted

    Hello Pooja,

    I believe that the issue comes from setting the AutoPostBack property to true, which triggers a postback when the user stars typing into the input of the WebDropDown, simply removing the AutoPostBack property or setting it to false, would resolve the issue.

    Please let me know if you need any further assistance.

    Regards,
    Ivan Kitanov