Your Privacy Matters: We use our own and third-party cookies to improve your experience on our website. By continuing to use the website we understand that you accept their use. Cookie Policy
975
Nothing showing up
posted

Can anyone see what i am doing wrong I cannot get the tree to populate with anything out of the table.

 

<%@ Page Language="VB" AutoEventWireup="false" CodeFile="selfreferencingdata.aspx.vb" Inherits="selfreferencingdata" %>

<%@ Register TagPrefix="ig" Namespace="Infragistics.Web.UI.DataSourceControls" Assembly="Infragistics35.Web.v9.1, Version=9.1.20091.1015, Culture=neutral, PublicKeyToken=7dd5c3163f2cd0cb" %>

<%@ Register TagPrefix="ignav" Namespace="Infragistics.WebUI.UltraWebNavigator" Assembly="Infragistics35.WebUI.UltraWebNavigator.v9.1, Version=9.1.20091.1015, Culture=neutral, PublicKeyToken=7dd5c3163f2cd0cb" %>

<%@ Register TagPrefix="ig" Namespace="Infragistics.Web.UI.NavigationControls" Assembly="Infragistics35.Web.v9.1, Version=9.1.20091.1015, Culture=neutral, PublicKeyToken=7dd5c3163f2cd0cb" %>

<html>

<head>

<title>Self Referencing Data Tree</title>

</head>

<body>

<form action="" runat="server">

<asp:ScriptManager runat="server" > </asp:ScriptManager>

 

<ignav:ultrawebtree ID="UltraWebTree1" runat="server" DataSourceID="WebHierarchicalDataSource1"

DefaultImage="ig_treeFolder.gif" HoverClass="" Indentation="20"

Width="163px" EnableAppStyling="True"

DefaultSelectedImage="ig_treeFolderOpen.gif" FileUrl=""

Font-Names="Microsoft Sans Serif" Font-Size="9pt" Height="297px" TargetFrame=""

TargetUrl="" WebTreeTarget="ClassicTree" >

<NodeEditStyle Font-Names="Microsoft Sans Serif" Font-Size="9pt">

</NodeEditStyle>

<Images>

<DefaultImage Url="ig_treeFolder.gif" />

<SelectedImage Url="ig_treeFolderOpen.gif" />

<ExpandImage Url="ig_treePlus.gif" />

<CollapseImage Url="ig_treeMinus.gif" />

</Images>

<DataBindings>

<ignav:NodeBinding DataMember="" />

</DataBindings>

<Levels>

<ignav:Level Index="0" />

</Levels>

<Nodes>

<ignav:Node Text="Root Node">

</ignav:Node>

</Nodes>

<SelectedNodeStyle BackColor="Navy" BorderStyle="Solid" BorderWidth="1px"

Cursor="Default" ForeColor="White">

<Padding Bottom="1px" Left="2px" Right="2px" Top="1px" />

</SelectedNodeStyle>

</ignav:ultrawebtree>

<asp:SqlDataSource ID="SqlDataSource1" runat="server"

ConnectionString="<%$ ConnectionStrings:App_834ConnectionString2 %>"

SelectCommand="SELECT [TransId], [FieldId], [Proposed_Value] FROM [tbl_enroll_changes]"></asp:SqlDataSource>

<ig:webhierarchicaldatasource id="WebHierarchicalDataSource1"

runat="server">

<DataRelations>

<ig:DataRelation ChildColumns="FieldId" ChildDataViewID="DefaultView"

ParentColumns="TransId" ParentDataViewID="DefaultView" />

</DataRelations>

<DataViews>

<ig:DataView ID="DefaultView" DataMember="DefaultView"

DataSourceID="SqlDataSource1" />

</DataViews>

</ig:webhierarchicaldatasource>

</form>

</body>

</html>