Your Privacy Matters: We use our own and third-party cookies to improve your experience on our website. By continuing to use the website we understand that you accept their use. Cookie Policy
340
WebDialogWindow div issue
posted

Hi,

I am using Infragistics controls version 10.2.20102.1011 with .Net Framework4 and Internet Explorer version  8.0.7600. I am using code similar to the code from your online samples to show and hide WebDialogWindow:

 

    <ig:WebScriptManager ID="WebScriptManager1" runat="server">

    </ig:WebScriptManager>

    <div id="buggedElement" style="padding:5px; border-color:Black; border-bottom-width:1px; border-bottom-style:solid;">

        <input id="btnShow" type="button" value="Show dialog window" onclick='showWindow("<%= wdTest.ClientID %>");' />

        <p style="color:Red">Click on bottom div border after web dialog has been closed!</p>

        <ig:WebDialogWindow ID="wdTest" runat="server" Height="300px" Width="400px" Modal="true" WindowState="Hidden" InitialLocation="Centered" Moveable="false">

            <Header CaptionText="Test">

            </Header>

            <ContentPane ScrollBars="Hidden">

                <Template>

                    <input id="btnHide" type="button" value="Close Me" onclick='hideWindow("<%= wdTest.ClientID %>")' />

                </Template>

            </ContentPane>

        </ig:WebDialogWindow>

    </div>

 

 

    <script type="text/javascript">

        function showWindow(windowClientId) {

            var webDialogCtrl = $find(windowClientId);

            webDialogCtrl.set_windowState($IG.DialogWindowState.Normal);

        }

        function hideWindow(windowClientId) {

            var webDialogCtrl = this.parent.$find(windowClientId);

            webDialogCtrl.set_windowState($IG.DialogWindowState.Hidden);

        }

    </script>

 

After the dialog window is shown and then closed you can experience strange behavior. When click inside any div or on any label with associated control to it which resides within div element, the dotted line border appears around it (see the screenshot in attached zip file). 

 

Is this some kind of bug or I am doing something wrong here.

 

I have attached my code sample without the content of my ig_res folder due to upload file limitation to this post.

 

WebDialogWindowSampleNoIgResIncluded.zip