Your Privacy Matters: We use our own and third-party cookies to improve your experience on our website. By continuing to use the website we understand that you accept their use. Cookie Policy
can't get the controls onto the vs toolbox, not even via "choose items"

I'm using VS 2008 x86 on a Vista x64 machine and I cannot add the Infragistics controls to the toolbox. 

The toolbox utility reports success but only creates a toolbox item group, without any items. Manually trying to add the items via "Choose items" doesn't work either, it just doesn't do anything.

I've tried to run VS as Admin and normal user: no difference.

I've started VS with the /log option: no relevant log entry

I've reset the toolbox repeatedly: no change

I've tried "choose items" and drag'n'drop: neither works

Interestingly, I've just noticed that there are a few controls I can add: The ones in Infragistics35.Web.v8.1 (WebSplitter etc) work, but I still can't add any control from Infragistics.WebUI.Misc.v8.1.dll  nor any control in any other Infragistis.WebUI.* dll.

What else should I try?