60
Alignment issue with editable webdatagrid in chrome
posted

Hi,

I am making my existing webdatagrid to editable webdatagrid by adding <RowAdding> and <RowEditing>. It works fine with IE but, in chrome there are few alignment issues like:

1. Editable controls are not properly aligned.

2.After horizontal scroll, controls stay at same place and just grid moves in the background.

3. Can not see existing value in the bottom of editable control the way we can see in IE.

Please find the attached image for more details:

Please help me fixing browser specific issue. 

Note: I am using 13.1 version of infragistics JS files and JQuery 1.7 version and below is the order of referring JS files:

<asp:ScriptReference Path="~/Scripts/jquery-1.7.min.js" />
                <%--<asp:ScriptReference Path="~/Scripts/jquery-1.9.1.js" />
                <asp:ScriptReference Path="~/Scripts/jquery-migrate-1.1.1.js" />--%>
                <asp:ScriptReference Path="~/Scripts/jquery-ui-1.9.2.custom.min.js" />
                <asp:ScriptReference Path="~/Scripts/MasterPage.js" />
                <asp:ScriptReference Path="~/Scripts/jquery.tmpl.js" />
                <asp:ScriptReference Path="~/Scripts/json2.js" />
                <asp:ScriptReference Path="~/Scripts/JScript.js" />
                <asp:ScriptReference Path="~/Scripts/jquery.cookie.js" />
                <asp:ScriptReference Path="~/Scripts/splitter.js" />
                <asp:ScriptReference Path="~/Scripts/jquery.ddslick.min.js" />
                <asp:ScriptReference Path="~/Scripts/Slider.js" />
                <asp:ScriptReference Path="~/Scripts/upptab.js" />
                <asp:ScriptReference Path="~/Scripts/infragistics/infragistics.loader.js" />
                <asp:ScriptReference Path="~/Scripts/js/utilities/sg.utilities.js" />
                <asp:ScriptReference Path="~/Scripts/js/ajax/sg.ajax.js" />
                <asp:ScriptReference Path="~/Scripts/js/controls/sg.web.controls.js" />
                <asp:ScriptReference Path="~/Scripts/jquery.dataTables.js" />
                <asp:ScriptReference Path="~/Scripts/flotr2.js" />
                <asp:ScriptReference Path="~/Scripts/jquery-sDashboard.js" />
                <asp:ScriptReference Path="~/Scripts/js/Events/webdatagridusercontrol.js" />

I have also tried using JS 1.9.1 instead of 1.7 but, it did not help me. Please let me know the fix for this browser issue.

Thanks,

Gaurav

  • 6305
    Offline posted

    Hello Gaurav,

    Thank you for the screenshot and the script references you have provided.

    I tested the alignment behavior you have described and I was not able to reproduce it.
    The best way for us to assist you is if you provide a small isolated sample that we can run and use for debugging locally. Having this information will help us further investigate this matter for you.

    Also please note that the 13.2 product has already had its last Service Release. For more details on the life-cycle of our products, you can take a look at the following link.

    If you have any questions, please let me know.