Your Privacy Matters: We use our own and third-party cookies to improve your experience on our website. By continuing to use the website we understand that you accept their use. Cookie Policy
1000
WebDialogWindow not shown through server side
posted

Hi,

I doesn't seem to get it to work. I used parts of your example to see if it could manage it.

 

Protected Sub btnShow_Click(ByVal sender As Object, ByVal e As System.EventArgs) Handles btnShow.Click
        Select Case WebDialogMsg.WindowState
            Case Infragistics.Web.UI.LayoutControls.DialogWindowState.Hidden
                WebDialogMsg.WindowState = Infragistics.Web.UI.LayoutControls.DialogWindowState.Normal
        End Select
 End Sub

 

<ig:WebDialogWindow ID="WebDialogMsg" runat="server" Height="120px" Width="400px" InitialLocation="Centered" Modal="True" Style="display:none;" StyleSetName="Claymation" StyleSetPath="~/ig_res" WindowState="Hidden">
            <Header CaptionText="Aviso">
            </Header>
            <ContentPane>
            <Template>
                <table cellpadding="4" cellspacing="4" border="0" class="modalInfragistics">
                <tr><td><asp:Label ID="lblAvisoMessage" runat="server" Text="" Font-Bold="true"></asp:Label></td></tr>
                </table>
                <table style="margin-left:auto;margin-right:auto;">
                <tr>
                    <td>
                        <table cellpadding="2" cellspacing="0" border="0" class="TableButtonOut" onmouseover="this.className = 'TableButtonOver';" onmouseout="this.className = 'TableButtonOut';" onclick="$find('<%= WebDialogMsg.ClientID %>').hide();return false;">
                        <tr>
                            <td align="center" valign="middle"><img id="Img7" src="~/Images/acceptar.png" runat="server" alt="" /></td>
                            <td align="center" valign="middle">OK&nbsp;&nbsp;&nbsp;</td>
                        </tr>
                        </table>
                    </td>
                </tr>
                </table>
            </Template>
            </ContentPane>
        </ig:WebDialogWindow>

  <asp:Button ID="btnShow" runat="server" Text="Show" />

 

When I use breakpoints it is definitly changing the WindowState, but the result remains, no modal dialog window. Any clues?

I forgot to tell you that I am using I am using asp.net 2.0 infragistics controls 2008 vol 3