Your Privacy Matters: We use our own and third-party cookies to improve your experience on our website. By continuing to use the website we understand that you accept their use. Cookie Policy
45
Parser Error Message: Unrecognized configuration section configsections.
posted

Hi all,

 

My web.config section looks like this,

 

<?xml version="1.0"?>

<!-- 

    Note: As an alternative to hand editing this file you can use the 

    web admin tool to configure settings for your application. Use

    the Website->Asp.Net Configuration option in Visual Studio.

    A full list of settings and comments can be found in 

    machine.config.comments usually located in 

    \Windows\Microsoft.Net\Framework\v2.x\Config 

-->

<configuration>

<configsections>

<section name="infragistics.web" type="System.Configuration.SingleTagSectionHandler,System, &#xA;     Version=1.0.3300.0, &#xA;     Culture=neutral, &#xA;     PublicKeyToken=b77a5c561934e089"/>

     <sectiongroup name="system.web.extensions" type="System.Web.Configuration.SystemWebExtensionsSectionGroup, System.Web.Extensions, &#xA;      Version=3.5.0.0, &#xA;      Culture=neutral, &#xA;      PublicKeyToken=31BF3856AD364E35">

<sectiongroup name="scripting" type="System.Web.Configuration.ScriptingSectionGroup, System.Web.Extensions, &#xA;       Version=3.5.0.0, &#xA;       Culture=neutral, &#xA;       PublicKeyToken=31BF3856AD364E35">

        <!--<section name="scriptResourceHandler" type="System.Web.Configuration.ScriptingScriptResourceHandlerSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="MachineToApplication"/>

        <sectionGroup name="webServices" type="System.Web.Configuration.ScriptingWebServicesSectionGroup, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>

          <section name="jsonSerialization" type="System.Web.Configuration.ScriptingJsonSerializationSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="Everywhere"/>

          <section name="profileService" type="System.Web.Configuration.ScriptingProfileServiceSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="MachineToApplication"/>

          <section name="authenticationService" type="System.Web.Configuration.ScriptingAuthenticationServiceSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="MachineToApplication"/>

          <section name="roleService" type="System.Web.Configuration.ScriptingRoleServiceSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="MachineToApplication"/>-->

</sectiongroup>

</sectiongroup>

</configsections>

<INFRAGISTICS.WEB formsDirectory="~/WebSchedule"/>

<system.web>

<!-- 

            Set compilation debug="true" to insert debugging 

            symbols into the compiled page. Because this 

            affects performance, set this value to true only 

            during development.

 

            Visual Basic options:

            Set strict="true" to disallow all data type conversions 

            where data loss can occur. 

            Set explicit="true" to force declaration of all variables.

        -->

<compilation debug="true" strict="false" explicit="true">

<assemblies>

<add assembly="Infragistics2.WebUI.WebSchedule.v6.2, Version=6.2.20062.34, Culture=neutral, PublicKeyToken=7DD5C3163F2CD0CB"/>

<add assembly="Infragistics2.WebUI.Shared.v6.2, Version=6.2.20062.34, Culture=neutral, PublicKeyToken=7DD5C3163F2CD0CB"/>

<add assembly="System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>

<add assembly="Infragistics2.WebUI.WebScheduleDataProvider.v6.2, Version=6.2.20062.34, Culture=neutral, PublicKeyToken=7DD5C3163F2CD0CB"/></assemblies>

<codeSubDirectories>

<add directoryName="VBCode"/>

<add directoryName="CSCode"/>

</codeSubDirectories>

</compilation>

<pages>

<namespaces>

<clear/>

<add namespace="System"/>

<add namespace="System.Collections"/>

<add namespace="System.Collections.Specialized"/>

<add namespace="System.Configuration"/>

<add namespace="System.Text"/>

<add namespace="System.Text.RegularExpressions"/>

<add namespace="System.Web"/>

        <add namespace="System.Web.configuration"/>

<add namespace="System.Web.Caching"/>

<add namespace="System.Web.SessionState"/>

<add namespace="System.Web.Security"/>

<add namespace="System.Web.Profile"/>

<add namespace="System.Web.UI"/>

<add namespace="System.Web.UI.WebControls"/>

<add namespace="System.Web.UI.WebControls.WebParts"/>

<add namespace="System.Web.UI.HtmlControls"/>

</namespaces>

</pages>

<!--

            The <authentication> section enables configuration 

            of the security authentication mode used by 

            ASP.NET to identify an incoming user. 

        -->

<authentication mode="Windows"/>

<!--

            The <customErrors> section enables configuration 

            of what to do if/when an unhandled error occurs 

            during the execution of a request. Specifically, 

            it enables developers to configure html error pages 

            to be displayed in place of a error stack trace.

 

        <customErrors mode="RemoteOnly" defaultRedirect="GenericErrorPage.htm">

            <error statusCode="403" redirect="NoAccess.htm" />

            <error statusCode="404" redirect="FileNotFound.htm" />

        </customErrors>

        -->

</system.web>

</configuration>

And am getting,
" Unrecognized configuration section configsections. "
as the error message....
Can anyone help me out of this problem...!!!

Parents
  • 4960
    Verified Answer
    posted

    vasanth_krt said:

    <configuration>
         <configsections>
    :     :
    :     :
    And am getting,
    " Unrecognized configuration section configsections. "
    as the error message....

    Change "configsections" to "configSections" with a capital S (do this to both the start tag and the end tag near the end of the file.)  XML is case-sensitive.

Reply Children
No Data