Your Privacy Matters: We use our own and third-party cookies to improve your experience on our website. By continuing to use the website we understand that you accept their use. Cookie Policy
430
WebHtmlEditor not working when copy-paste from MSWord
posted

We have tried to copy text from MSWord to Infragistics WebHtmlEditor and there are problems when using lists: A list in MSWord is copied to WebHtmlEditor and it is represented in html as "<p>" not as "<ol>" or "<ul>".

Example:

In MSWord (some nested lists):

    1. First item

        a. subitem A

        b. subitem B

    2. Second item

Copy-paste in WebHtmlEditor, the html generated is:

    <p>1. First item</p>

    <p style="margin:0 0 0 72pt">a. subitem A</p>

     ...

We have detected this problem in IE10 or less, and also in Chrome. In IE11 it works properly.

We are using Infragistics v14.2

Please could you help us with this issue?

Regards

Parents
  • 2651
    Offline posted

    Hello,

     

    Clipboard access varies quite a bit between browsers ( JavaScript is by security design usually denied access, except IE that has an option to allow it) – which is to say usually the paste happens through system shortcuts like ctrl-V which is totally dependent on what HTML word puts in the clipboard and how the browser handles it.

     

    The behaviors you are seeing is actually new, it’s more in the lines of “Pasting Word HTML never really generated good markup before” and apparently there is some extra handling added to IE11 to handle pasting rich text. This is again not even related to the control and affects other web apps and content coming from other editors (VS comes to mind).

     

    There might be a way to fix the content right before the action finishes executing but be warned it’s possibly quite a feat, especially I you attempt more than one formatting type support.

     

    Regards,

    Damyan Petev

    Associate Software Developer

    Infragistics, Inc.

     

Reply Children
No Data