Your Privacy Matters: We use our own and third-party cookies to improve your experience on our website. By continuing to use the website we understand that you accept their use. Cookie Policy
40
Win.UltraWinGrid.DocumentExport not in versionless ZIP
posted

Hello there,

my company has built its own ERP Insurance software using a Windows Forms application (VB).

We are using Infragistics controls, providing us a rich OOTB UI and functionality. Currently we're using the latest version (16.2).

Upgrading the version is quite a bit of work, due to the fact we have a lot of projects and references, resulting in multiple merge conflicts for our development team.

Therefore we thought it would be a good idea to start using the versionless assemblies, and I copied al those DLL's from the ZIP file to a shared lib folder. So we only have to copy newer assemblies, and references do not have to be changed.

As I was replacing the old references with the new ones I ran into the problem that some assemblies are NOT in the ZIP. Like Win.UltraWinGrid.DocumentExport and Win.UltraWinGrid.ExcelExport. And probably there will be more, which I have not seen yet.

Kind of stuck now, tried some manual copying/renaming of these DLL's; that won't work as they require the versioned files.

Does anyone know a solution for this? And do you agree with the way we are trying to use the versionless assemblies?

Parents
  • 1225
    Verified Answer
    Offline posted

    Hi,
    Even though the topic is bit outdated with actual installed folder path and folder names , this will give an idea on how you can use the version free assemblies.
    http://www.infragistics.com/help/winforms/introduction-using-version-free-assemblies

    It is really surprising to me that the dlls are missing from the Unzipped Folder. Because I see the dlls when I unzip the folder under the Installed folder path as you can see in the attached screenshot.

    So I just wanted to clarify a few things to understand clearly what you experience and why it is happening.
    1. Do you have 16.2 installed on the machine?
    2. Which version of 16.2 do you have?
    3. Are you using any Patch? And in that case have you installed the patch or just copied folder with the dlls?

    Thanks,
    Josheela

Reply Children