Your Privacy Matters: We use our own and third-party cookies to improve your experience on our website. By continuing to use the website we understand that you accept their use. Cookie Policy
Deployment of Win appl with WinGrid

Hi -

I am trying to deploy my WinForm application that contains WinGrid.  I made my deployment package using ClickOnce ( in VS2008, I followed the steps published.  In Project Property, I click Publish, specified the Pub Loc and Installation Folder... and in the Prerequisites I click "Download Prerequistes from the same location as my application" and specify where the setup.exe is.  And I copied the Infragistics2.Shared.v8.3.dll in there. 

But when I click the setup.exe trying to install my application. The setup can not complete with the error message: "Unable to install or run the application.  The application requires that assembly Infragistics2.Shared.v8.3 version 8.3.20083.1009 be installed in the Global Assembly cache (GAC) first....  I thought the setup.exe will automatically install (or copy) the Infragistics dll for me as part of the deployment but it did not.

 Please help, or point to some document to show how to create the deployment package properly. 

No Data
  • 45049

    The following article from our online help documentation of NetAdvantage for Windows Forms 2008 Volume 3 leads to other articles that provide general information about deploying Windows Forms applications:
    Deploying Your Application (Windows Forms)

    Amiram's suggestion about setting the "Publish Status" to "Include" is an important additional step for ClickOnce deployment.

    I generally prefer not to advise setting the CopyLocal property to true on any NetAdvantage reference.  Doing so may cause you issues at design-time if you forget to set it back to false; these same iasues would also occur with any .NET assembly that includes designer code, including System.Windows.Forms.dll.  When I last tested a ClickOnce deployment, I didn't need to set CopyLocal to true for the deployment to work.  If it helps you to set this, however, then by all means do so.

No Data