Your Privacy Matters: We use our own and third-party cookies to improve your experience on our website. By continuing to use the website we understand that you accept their use. Cookie Policy
30
WindowsFormsHost issue with infragistics controls
posted

Hi,

My application is a WPF window, in which i'm hosting a WPF pane with winform control using WindowsFormsHost. 
Winform control has infragistics control mainly using ultratree.

When this pane hosting WIndowsFormsHost is in unpinned state or it is in tabbed state with some other pane, following issues occur:
1) Scrollbar stop working, it doesn't scroll with mouse wheel, it only works by clicking on the down and up arrows of the scrollabr

2) Checkbox state cannot be changed, it cannot be checked/unchecked its state remains same.

3) Drag  drop of tree stopped working, no node can be dragged.

4) Tooltips doesn't show up when mouse is hovered on them

All these issues don't occur with normal winform controls being hosted in WPF window using WIndowsFormsHost. these are just happening with the infragistics controls.

Please let me know, what needs to be done to make these work, I've just changed my winform window into WPF and it is a big show stopper for my application.

Thanks,

Tayyaba

Parents
  • 29130
    Verified Answer
    Offline posted

    Hello Tayyaba,

    I have been investigating into these behaviors that are not working correctly for you using the UltraTree in a WindowsFormsHost in a WPF application. You mentioned that you were hosting the WindowsFormsHost in a pane, and so at the moment, I am using the WPF XamDockManager to facilitate this. In doing so, I cannot seem to reproduce any of the behaviors that you are seeing.

    It is worth noting though, that over the years, there have been a couple of bugs fixed relating to our Windows Forms controls working incorrectly while placed in a WPF application via a WindowsFormsHost. My tests were made against version 18.1.20181.88 of Infragistics for Windows Forms 2018. Is this the same version you are using? If not, then which version are you testing against?

    I have attached the sample project I used to test this.  Please test this project on your PC; whether or not it works correctly may help indicate the nature of this problem.

    If the project does not work correctly, this indicates either a problem possibly specific to your environment, or a difference in the DLL versions we are using.

    If the project does show the product feature working correctly, this indicates a possible problem in the code of your application.  It will help if you can provide a small, isolated sample application that demonstrates the behavior you are seeing.

    Or, if this sample project is not an accurate demonstration of what you're trying to do, please feel free to modify it and send it back, or send a small sample project of your own if you have one.

    Please let me know if you have any other questions or concerns on this matter.

    WindowsFormsHostTest.zip

Reply Children
No Data