Your Privacy Matters: We use our own and third-party cookies to improve your experience on our website. By continuing to use the website we understand that you accept their use. Cookie Policy
100
problems showing multi select combo box
posted

Hello,

I'm using XamcomboEditor with allowMultipleSelection=True and I'm binding SelectedItems to an ObservableCollection<object>. But my problem is that my collection doesn't fire CollectionChanged event when I update its content via the XamcomboEditor. Can you please advise ?

Thanks

Parents
No Data
Reply
  • 28910
    Offline posted

    Hello Aziz,

    I have been investigating into this issue that you are seeing where the ObservableCollection<object>.CollectionChanged event is not firing, and I cannot seem to reproduce this behavior you are seeing.

    I have attached the sample project I used to test this.  Please test this project on your PC; whether or not it works correctly may help indicate the nature of this problem.

    If the project does not work correctly, this indicates either a problem possibly specific to your environment, or a difference in the DLL versions we are using.  My test was performed using version 18.1.20181.82 in Infragistics for WPF 2018.1.

    If the project does show the product feature working correctly, this indicates a possible problem in the code of your application.  It will help if you can provide a small, isolated sample application that demonstrates the behavior you are seeing.

    Or, if this sample project is not an accurate demonstration of what you're trying to do, please feel free to modify it and send it back, or send a small sample project of your own if you have one.

    Please let me know if you have any other questions or concerns on this matter.

    ComboSelectionTest.zip

Children
No Data