35
XamDataCards disable horizontal scrollbar if fields larger than view
posted

Hi

I am using XamDataCards to display a single column of cards. The layout of my card is like that in the Custom Card Layout sample in that I have a picture in column 0 row 0 and a number of text fields in column 1. One of the text fields in column 1 exceeds the length of the card and the field that has the image starts off larger than required, so I am setting Width="Auto" in my field settings which is reducing the image field to be just slightly larger than the image and expands column 1 to the length of the large field. The problem is this results in a horizontal scrollbar to appear on the cards which I do not want. I just want the content of the field to be cut at the edge of the card.

How do I disable the horizontal scroll bar from appearing?

Cheers

Parents
No Data
Reply
  • 27540
    Offline posted

    Hello Michael,

    I have begun investigating into this behavior that you are seeing, but I'm not entirely sure I completely understand the behavior that you are seeing in this case. I am unsure if you are seeing the horizontal scrollbar show up on the data cards themselves, or the entirety of the control in this case, although it sounds like the former.

    Would it be possible for you to please provide the relevant code that you are using for your XamDataCards control or perhaps an isolated sample project so that I may ensure that I give you accurate information for how to prevent the horizontal scrollbar in this case?

    Please let me know if you have any other questions or concerns on this matter.

Children