Your Privacy Matters: We use our own and third-party cookies to improve your experience on our website. By continuing to use the website we understand that you accept their use. Cookie Policy
50
XamDataGrid nondeterministic/inconsistent behaviour Column formatting
posted

I'v attached a sample application.

The problem is visible in the first column (Name = "Unexpected Behavior").

Column two and three are added to compare the behavior.

Problem occurs if you bind to a decimal Property and set "Field.Format = string.empty" AND "EditAsType = typeof(decimal?)". 

Actual behavior:

  1. start the application
  2. the main window is shown and you see the first 15 of 50 rows
  3. the initially visible (rendered rows) are formatted
    • as plain numbers: "1" or "0"
    • without decimal places
    • without currency symbol
  4. slowly scroll down to see more rows
    1. Actual behavior: you will see some of the new rows are rendered as "1,00 €" and "0,00 €"
    2. Expected behavior: formatting remains identical with the initial rendered rows "1" and "0"
  5. scroll a few times completely down and up
    1. Actual behavior: you will see more and more (and finally all) of the new rows are rendered as "1,00 €" and "0,00 €"
    2. Expected behavior: formatting remains identical with the initial rendered rows "1" and "0"

IgDataGridFormatBug.zip

Parents
No Data
Reply
  • 5315
    Offline posted

    Hello jens,


    Thank you for posting. I am able to reproduce the behavior you described for the first column formatting.

    I have submitted this development issue for further investigation (260745) and have created a private case (CAS-200153-B1F6Y2) where I will provide you with further information.

    Please let me know if you need more information.

    Sincerely,
    Divya Jain
    Associate Software Developer

Children
No Data