Your Privacy Matters: We use our own and third-party cookies to improve your experience on our website. By continuing to use the website we understand that you accept their use. Cookie Policy
15
About XamDiagram v15.1 product version
posted

Hi everyone,

I work in a corporate company. We use in Infragistics v15.1  our projects. I have a problem. I want to use XamDiagram but Visual studio doesn't build because XamDiagram use InfragisticsWPF4.dll basically. InfragisticsWPF4 product version is 15.1.20151.1000 but XamDiagram product version is 15.1.20151.2251. So I get this error: 

Severity Code Description Project File Line Suppression State
Error CS1705 Assembly 'InfragisticsWPF4.Controls.Charts.XamDiagram.v15.1' with identity 'InfragisticsWPF4.Controls.Charts.XamDiagram.v15.1, Version=15.1.20151.2251, Culture=neutral, PublicKeyToken=7dd5c3163f2cd0cb' uses 'InfragisticsWPF4.v15.1, Version=15.1.20151.2251, Culture=neutral, PublicKeyToken=7dd5c3163f2cd0cb' which has a higher version than referenced assembly 'InfragisticsWPF4.v15.1' with identity 'InfragisticsWPF4.v15.1, Version=15.1.20151.1000, Culture=neutral, PublicKeyToken=7dd5c3163f2cd0cb'. 

I don't have XamDiagram product version 15.1.20151.1000. If I change InfragisticsWPF4 product version 1000 to 2251 then other projects fail.

I don't find XamDiagram product version 15.1.20151.1000. 

Is there anyone  who can help me?

Thank you.

  • 240
    Offline posted

    Hello Mustafa,

    A possible reason for the exception thrown might be if the dll-s you're using are referencing different versions of the product. When change references to point  from build 1000 to 2251 please make sure that all dll-s in all projects (or its dependencies) have v15.1.20151.2251.

    Additionally, I installed v15.1.20151.1000 and I was able to find the XamDiagram dll on my side, so there is no reason to not have it on your side as well. Please search for it in the Ingfagistics product folder and if you still could not find it my suggestion is to contact our sales department at sales@infragistics.com in order to receive a back key and install the product again.

    Please keep in mind that according to our support policy Infragistics products have one year of product service releases and three years of developer support. This means that version 15.1 is considered retired and it is no longer eligible for Developer Support Services.  More about the Infragistics product lifecycle can be found here.

    Sincerely,
    Teodosia Hristodorova
    Associate Software Developer