Your Privacy Matters: We use our own and third-party cookies to improve your experience on our website. By continuing to use the website we understand that you accept their use. Cookie Policy
960
XamGrid TemplateColumn Howto Enter edit mode when entered with tab
posted

Hi, I have a XamGrid with Two editable columns, I use Template Columns because I need to control Filtering and editors.

I've understood that to use the editing settings to activate or deactivate editing I have to use ItemTemplate and EditTemplate and it works

Just one thing I can not achieve, even if I've set

<ig:XamGrid.EditingSettings>
 <ig:EditingSettings AllowEditing="{Binding AllowEdit}"  
		 IsMouseActionEditingEnabled="SingleClick" 
                 IsEnterKeyEditingEnabled="{Binding IsInEditMode}" 
		 IsF2EditingEnabled="False" 
                 IsOnCellActiveEditingEnabled="{Binding IsInEditMode}" />
</ig:XamGrid.EditingSettings>

When the cells are "browsed" using the Tab key and AllowEditing is set to Cell, even if the IsOnCellActiveEditingEnabled
is set to True, the cell is selected and active but not enters edit mode.
What do I have to do??? is there an event where to perform an enter edit mode? Is there some other editing setting?
thank you in advance
bye
Parents
  • 33530
    Offline posted

    Hello Sabrina,

    Thank you for your post.

    I have been investigating this issue, but I have not been able to reproduce this behavior that you are seeing. I set the IsOnCellActiveEditingEnabled, IsEnterKeyEditingEnabled, and AllowEditing properties to True, True, and Cell, respectively, and the tab navigation editing seems to work for me. Are you sure your bindings are working correctly? Do you have any binding expression errors in the Visual Studio output window when running your project?

    I have attached the sample I used to test this. Please test this project on your PC. If the project works correctly, it may indicate a problem specific to your environment or a difference in the specific DLL versions we are using. My test was performed using version 14.2.20142.2178 in Infragistics for WPF 2014 Volume 2.

    If the project does show the feature working correctly, this indicates a problem in the code of your application. It will help if you could provide a small, isolated sample application that demonstrates the behavior you are seeing.

    Please let me know if you have any other questions or concerns on this matter.

    Sincerely,
    Andrew
    Associate Developer
    Infragistics Inc.
    www.infragistics.com/support

    XamGridTabEditingCase.zip
Reply Children
No Data