no intellisense

Not Answered This post has 0 verified answers | 3 Replies | 2 Followers Thread's RSS feed.

mark
Points 820
Replied On: Tue, Feb 28 2017 7:48 AM Reply

Ive just started trying out infragistics and am following the Grid -> basic editing sample.  For no reason I can see, intellisense has just randomly stopped working.  It was working ok to start with, then stopped.  Can anyone tell me why this could happen ?  This is my view code

@using Infragistics.Web.Mvc
@using ViewModels.Contracts
@model IQueryable<ViewModels.Contracts.ContractViewModel>

@{
Layout = null;
}

<!DOCTYPE html>

<html>
<head>
<title></title>

<style type="text/css">
input.button-style {
margin-top: 10px;
}
</style>
</head>
<body>

@(Html.Infragistics()
.Grid(Model)
.ID("Grid")
.Height("500px")
.Width("100%")
.AutoGenerateColumns(false)
.AutoGenerateLayouts(false)
.RenderCheckboxes(true)
.PrimaryKey("ContractId")
.Columns(column =>
{
//column.For(x => x.ContractId).HeaderText("Contract ID").Width("10%");
column.For(x => x.ContractDate).HeaderText("Contract Date").Width("15%");
column.For(x => x.ContractEndUserOrg).HeaderText("Org Id").Width("20%");
column.For(x => x.ContractOrgName).HeaderText("Org Name").Width("25%");
column.For(x => x.ContractCurrency).HeaderText("Currency").Width("10%");
column.For(x => x.ContractStartDate).HeaderText("Start Date").Width("15%");

})
.Features(feature =>
{
feature.Updating().ColumnSettings(cs =>
{
//cs.ColumnSetting().ColumnKey("ContractId").ReadOnly(true);
cs.ColumnSetting().ColumnKey("ContractDate").EditorType(ColumnEditorType.DatePicker).Required(true);
cs.ColumnSetting().ColumnKey("ContractEndUserOrg").Required(true);
cs.ColumnSetting().ColumnKey("ContractOrgName").Required(true);
cs.ColumnSetting().ColumnKey("ContractCurrency").Required(true);
cs.ColumnSetting().ColumnKey("ContractStartDate)").Required(true).EditorType(ColumnEditorType.Date);
});
feature.Sorting();
})
.DataSourceUrl(Url.Action("GetContracts"))
.UpdateUrl(Url.Action("ContractsSaveData"))
.DataBind()
.Render()
)

there is no longer any intellisense so i cant select things like object properties, so if I type

column. ----- nothing !, no suggestions

anyone help ?

  • Post Points: 20

All Replies

[Infragistics] Vasya
Points 16,295
Infragistics Employee
Replied On: Wed, Mar 1 2017 6:46 AM Reply

Hello,

Thank you for posting in our community.

Visual Studio reads public methods and options from the corresponding dll loaded. Having this in mind please check whether Infragistics.Web.Mvc dll is correctly referenced. Afterwards you can try reloading the project.

Test this suggestions and let me know If you need any further assistance afterwards. 

Regards,

Vasya Kacheshmarova,
Developer Support Engineer,
Infragistics

  • Post Points: 20
mark
Points 820
Replied On: Wed, Mar 1 2017 7:33 AM Reply

Infragistics.Web.Mvc dll is correctly referenced and copy local is set to true

  • Post Points: 20
[Infragistics] Vasya
Points 16,295
Infragistics Employee
Replied On: Wed, Mar 1 2017 10:39 AM Reply

Hello Mark,

Did you try unloading your project and reloading it again?

Regards,

Vasya Kacheshmarova,
Developer Support Engineer,
Infragistics

  • Post Points: 5
Page 1 of 1 (4 items) | RSS