Your Privacy Matters: We use our own and third-party cookies to improve your experience on our website. By continuing to use the website we understand that you accept their use. Cookie Policy
1370
'Infragistics' is undefined
posted
There was a old post with the same error; but, there was no resolution, I've upgraded to the latest release and still getting the error. Entries in web.config.

Version=13.2.20132.2028
 <package id="AjaxControlToolkit" version="7.1213" targetFramework="net40" />
  <package id="AjaxMin" version="5.7.5124.21499" targetFramework="net40" />
  <package id="HtmlAgilityPack" version="1.4.6" targetFramework="net40" />
  <package id="jQuery" version="2.1.0" targetFramework="net40" />
  <package id="Microsoft.Data.Edm" version="5.6.0" targetFramework="net40" />
  <package id="Microsoft.Data.OData" version="5.6.0" targetFramework="net40" />
  <package id="Microsoft.Data.Services.Client" version="5.6.0" targetFramework="net40" />
  <package id="Microsoft.WindowsAzure.ConfigurationManager" version="2.0.3" targetFramework="net40" />
  <package id="Newtonsoft.Json" version="6.0.1" targetFramework="net40" />
  <package id="System.Spatial" version="5.6.0" targetFramework="net40" />
  <package id="WindowsAzure.Storage" version="3.0.3.0" targetFramework="net40" 

Getting the 'Infragisitcs' is undefined on line:
Sys.Application.add_init(function() {
    $create(Infragistics.Web.UI.WebDataGrid, {"id":"MainContent_WebDataGrid1","name":"WebDataGrid1","props":[[[,2,,],{"c":{"hdlay":false,"dcwidth":"","rac":"ig_RedPlanetAlt igg_RedPlanetAlt","ea":"false","_pi":"[\"../ig_res/Default/images/ig_ajaxIndicator.gif\",,,\"ig_AjaxIndicator\",,1,,,,\"ig_AjaxIndicatorBlock\",,3,,3,\"Async post\"]","ecr":false,"uid":"ctl00$MainContent$WebDataGrid1","shH":true,"en":"true","hmcf":false,"incolcnt":"0","ocs":1,"we":"false","cbdci":0,"pi":"[]","sv":"1","ti":0,"cbc":0}}],[[[[0]],,],[[[2]],,],[[["Selection",1,0,1,,,,],{"c":{"sc":"ig_RedPlanetSelected igg_RedPlanetSelectedCell","sr":"igg_RedPlanetSelectedRowSelector","si":"igg_RedPlanetSelectedRowSelectorImage","ehs":false,"sh":"igg_RedPlanetSelectedHeader"}}],,,["RowSelectionChanged::1"]],[[["RowSelectors"],{"c":{"rsc":"ig_RedPlanetHeader igg_RedPlanetRowSelector","rn":true}}],,,[]]],[{'0':[[1,"igede12b8d",0,,,""],{"c":{"css":"","headTxt":"ApplicationID","cf":"","type2":6,"htmlEnc":true,"type":"number","footTxt":"","fcs":1,"key":"ApplicationID","dfn":"ApplicationID","vIndex":0,"nullable":false}}],'1':[[0,,0,,,""],{"c":{"css":"","headTxt":"Select An Application:","cf":"","type2":0,"htmlEnc":true,"type":"string","footTxt":"","fcs":1,"key":"ApplicationName","dfn":"ApplicationName","vIndex":1,"nullable":false}}]},{}],[],]}, null, null, $get("MainContent_WebDataGrid1"));


In web.config:
<pages>
      <controls>
        <add tagPrefix="ajaxToolkit" assembly="AjaxControlToolkit" namespace="AjaxControlToolkit"/>
        <add tagPrefix="ig" namespace="Infragistics.Web.UI.GridControls" assembly="Infragistics4.Web.v13.2, Version=13.2.20132.2028, Culture=neutral, PublicKeyToken=7dd5c3163f2cd0cb"/>
        <add tagPrefix="ig" namespace="Infragistics.Web.UI.LayoutControls" assembly="Infragistics4.Web.v13.2, Version=13.2.20132.2028, Culture=neutral, PublicKeyToken=7dd5c3163f2cd0cb"/>
        <add tagPrefix="ig" namespace="Infragistics.Web.UI.ListControls" assembly="Infragistics4.Web.v13.2, Version=13.2.20132.2028, Culture=neutral, PublicKeyToken=7dd5c3163f2cd0cb"/>
        <add tagPrefix="ig" namespace="Infragistics.Web.UI.EditorControls" assembly="Infragistics4.Web.v13.2, Version=13.2.20132.2028, Culture=neutral, PublicKeyToken=7dd5c3163f2cd0cb"/>
        <add tagPrefix="ig" namespace="Infragistics.Web.UI" assembly="Infragistics4.Web.v13.2, Version=13.2.20132.2028, Culture=neutral, PublicKeyToken=7dd5c3163f2cd0cb"/>
      </controls>
    </pages>