Your Privacy Matters: We use our own and third-party cookies to improve your experience on our website. By continuing to use the website we understand that you accept their use. Cookie Policy
Control Configurator Data Binding


I have been using the new controls and control configurator in the Ultimate UI for Xamarin Trial for the last week or so and I have run into the following error:

"Could not load file or assembly 'System.Collections.Immutable, Version=, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT:0x80131040) Unable to parse control XAML. Please ensure your project build and try to configure control again."

I ran into this error when I tried to open the control configurator for a data bound pie chart. Initially, I was not able to open the control configurator for this particular pie chart (visual studio repeatedly crashed when I tried) so I removed all the XAML tags for it, including the data binding tags, and finally I was able to open the control configurator.

Once I had the control configurator open, I went to re-establish my data bindings and that was when the error presented. This error now shows up on any control that I try to data bind using the control configurator.

Please advise as to what could be causing this error and how I can avoid it in the future

Thank you!