Your Privacy Matters: We use our own and third-party cookies to improve your experience on our website. By continuing to use the website we understand that you accept their use. Cookie Policy
325
Unable to upgrade Igniteui angular and angular versions
posted

Dear team, 

I am trying to upgrade my angular v13 and igniteui-angular@13.1 to latest. But I am getting the following issue 

 Migration failed: 404 Not Found - GET registry.npmjs.org/@infragistics/igniteui-angular - Not found

I am trying to do this on my MacBook Pro.

I tried the following commands and then upgrade but still no result.

npm config set @infragistics:registry packages.infragistics.com/.../

npm config set //packages.infragistics.com/npm/js-licensed/:always-auth=true

npm config set //packages.infragistics.com/npm/js-licensed/:_auth={myToken}

I tried all commands with —force but no luck.

Please let me know if this is something to do with macOS or if there is a solution

Parents
  • 2560
    Offline posted

    Hi Rameez,

    Thank you for posting to Infragistics Community!

    In order to upgrade from version 13 to the latest, which is 16.0.x, my suggestion is to upgrade both Angular’s and Ignite UI for Angular’s versions sequentially by leveraging the “ng update” command. I believe you will find our Update Guide quite informative on the matter. Additionally, the CLI offers automatic migrations, which update much of the code that requires modification. Still, there are some manual changes that cannot be covered by the migrations and they are all listed in the above referenced topic. For your case, you will need to go from “From 13.1.x to 13.2.x” to “From 15.1.x to 16.0.x” in the process of upgrading. In case you are not using a certain feature among the described, no changes are to be made.

    Regarding the error you are encountering, what I can say is that it appears rather related to licensing. The licensed package is named “@infragistics/igniteui-angular”, while the trial one is only “igniteui-angular”. The error indicates not being able to find our licensed registry. So, I am wondering if you had followed the steps from our Licensing topic to setup the licensed feed?

    Consequently, I am not convinced this should be a Mac-related issue, however, please note that there are alternative approaches in case the npm version is up to 8, or 9 and above. They are listed here.

    If you are still facing difficulties, you could also try to set it up with an Access Token.

    Finally, to verify against a potential subscription issue, I would ask you to please try logging into our ProGet site and see if you are able to access the Ignite UI for Angular packages there. You would use the Infragistics account credentials.

    Best regards,
    Bozhidara Pachilova
    Associate Software Developer

Reply Children