Your Privacy Matters: We use our own and third-party cookies to improve your experience on our website. By continuing to use the website we understand that you accept their use. Cookie Policy
180
Updating feature with a POST request instead of a PUT request.
posted

Hello,

I am currently using a RESTDatasource to populate my igGrid and I d'like to know if there is a way to change the update behaviour to make a POST request instead of a PUT request. I am currently using a IIs WebServer and it can be difficult to use PUT requests when WebDav is installed (I can't be sure it won't be present). In the meantime, I'm still looking for a solution to make it work (WebDav + PUT Request) but if there is a POST solution it could be an acceptable fall back for me.

Thank you!

Parents
No Data
Reply
  • 180
    Verified Answer
    Offline posted

    Me again,

    Just for information I found a way to make PUT/DELETE requests work with WebDav & WebAPI so I will use the REST standard implementation. The error I had was 500.21 (Internal Server Error Handler "ExtensionlessUrlHandler-Integrated-4.0" has a bad module "ManagerPipelineHandler" in its module list), this was linked to WebDav being installed. 

    2 Solutions  : 

         - 1 Disable WebDav  :

               - In IIs configuration click on the website, on the middle panel double click on "WebDav Authering Rules", on the right panel clic on "Disable WebDav". /!\ This means no web application can use WebDav under this site.

         - 2 Keep WebDav on the site & disable WebDAV for the web application / WebApi : 

                - Modify your web application web.config as follow: 

               

    <system.webServer>
    	<modules runManagedModulesForWebDavRequests="true">
                  <remove name="WebDAVModule" />
                  ........
        <modules>
        <handlers>
                  <remove name="WebDAV" />
                  .......
        </handlers>
                  .....
    </system.webServer>
     

         Add the attribut runManagedModulesForWebDavRequests="true" to the modules xml element (cf. https://docs.microsoft.com/en-us/iis/configuration/system.webserver/modules/)

        Add the <remove name="WebDAVModule"> to the "modules" xml element.

        Add the <remove name="WebDAV"> to the "handlers" xml element.

    Hope it helps somone ^^.

    Thanks for all your help and suggestions 

Children