Your Privacy Matters: We use our own and third-party cookies to improve your experience on our website. By continuing to use the website we understand that you accept their use. Cookie Policy
40
Unable to download on iPads using Shareplus Enterprise on OTA
posted

We have the Shareplus enterprise license and have tried today to deploy in production on iPads. It is on OTA link with our extranet. The app uses Sharepoint. Within the site, we have the .ipa file, manifest.plist, and the provisioning file.

We have the following settings and observations:

  • On some install on iPads, it was successful and some fails with the error "Unable to download shareplus at the moment. Please try again later." All iPads have the same iOs.
  • It has no load balancer, thus downloading from one IIS server only.
  • Our logs shows the same files download for successful and unsuccessful installs.
  • Provisioning file is up to date and not expired.
  • Logging into the application, we use the same credentials.

After multiple attempts, the following last resorts work:

  1. Doing a factory reset, installs was successful.
  2. We tried with MDM and it works but MDM is not enterprise wide yet and we want a solution without MDM.
  • 9490
    Offline posted

    Hello Andy,

    Thank you for your support request!

    I'm afraid this is rather common in OTA app deployment. If there's a temporary network issue, like low bandwidth, and the app installation takes too long, as per iOS' parameters, it is terminated.

    Typically, trying again later solves the issue and lets the app installation go through.

    As you state, MDM solutions are optimal for corporate scenarios.

    I hope this helps answering your question. Let me know if I can be of further help.

    Regards,